summaryrefslogtreecommitdiff
path: root/sys-apps/ethq/ethq-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ethq/ethq-0.5.0.ebuild')
-rw-r--r--sys-apps/ethq/ethq-0.5.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sys-apps/ethq/ethq-0.5.0.ebuild b/sys-apps/ethq/ethq-0.5.0.ebuild
deleted file mode 100644
index a22a412539ae..000000000000
--- a/sys-apps/ethq/ethq-0.5.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV=${PV//./_}
-MY_P=${PN}-${MY_PV}
-
-inherit toolchain-funcs
-
-DESCRIPTION="Ethernet NIC Queue stats viewer"
-HOMEPAGE="https://github.com/isc-projects/ethq"
-SRC_URI="https://github.com/isc-projects/ethq/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="sys-libs/ncurses:0="
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- default
-
- # Respect FLAGS
- sed -i \
- -e '/CXXFLAGS/s/= -O3/+=/' \
- -e 's/ -Werror//' \
- -e '/LDFLAGS/s/=/+=/' Makefile || die "sed failed for Makefile"
-
- if ! use test ; then
- sed -i '/TARGETS/s/ethq_test//' Makefile \
- || die "sed failed for USE flag test"
- fi
-}
-
-src_compile() {
- # override for ncurses[tinfo]
- emake CXX="$(tc-getCXX)" LIBS_CURSES="$($(tc-getPKG_CONFIG) --libs ncurses)"
-}
-
-src_test() {
- local driver
- for driver in tests/* ; do
- "${S}"/ethq_test "${driver##*/}" "${driver}" \
- || die "test failed on ${driver}"
- done
-}
-
-src_install() {
- einstalldocs
- dobin ethq
-}