summaryrefslogtreecommitdiff
path: root/sys-apps/edac-utils
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/edac-utils')
-rw-r--r--sys-apps/edac-utils/Manifest7
-rw-r--r--sys-apps/edac-utils/edac-utils-0.18-r1.ebuild53
-rw-r--r--sys-apps/edac-utils/edac-utils-0.18.ebuild8
-rw-r--r--sys-apps/edac-utils/files/edac.init16
-rw-r--r--sys-apps/edac-utils/files/edac.service11
-rw-r--r--sys-apps/edac-utils/metadata.xml11
6 files changed, 97 insertions, 9 deletions
diff --git a/sys-apps/edac-utils/Manifest b/sys-apps/edac-utils/Manifest
index 6b7428a8a312..1b3c095eadfa 100644
--- a/sys-apps/edac-utils/Manifest
+++ b/sys-apps/edac-utils/Manifest
@@ -1,3 +1,6 @@
+AUX edac.init 336 BLAKE2B 7ebffaf4d4431977d607448f43beb5f17903e28a1aef3a8445e0c83a267a221e7fdaa6f0aa1860123da44dfbef00c1861f8eaf93d9968bbfc0896ad9de39ea5e SHA512 51936a92d46f324964d8149d69c9e9260428030e3bf23e4a46aabc716d04ddb06acf05c55a63747436e0a3b3a2775f3725a8adae594af2b1a6ae234143338f85
+AUX edac.service 230 BLAKE2B a38c84a994bcaf884ed1a23c406971c57c4353a226029d5c08cd71481ca888dae91c5a6c6422a20181319c3199d2e97fb1985a05415ffc9f1cdad318281f50d6 SHA512 de8838c5f2227e4c81c8b571dd117ac90aeabeb082b767e84bd208a80c24496f3bd5105fb15fab890ea3224616646a882d12dc7c37af6d0e554f95cd8d081b7d
DIST edac-utils-0.18.tar.gz 285909 BLAKE2B 7d2662daf94c4ff796760b4863837861015397016bb79202baaa194608b61450d6749981cec621571267ac818a09af758167d2d768513e7d5bf7e763aed7ee51 SHA512 5c81b11c28e8fb3198f2d656171493877393024d9e31233c252d358d8029aa83065e7b66ea87d742518f710466c9ba7dfcf57a1641374ce169cf95fd379101fa
-EBUILD edac-utils-0.18.ebuild 1085 BLAKE2B d8509b37fab1eb499ea479ff82a70b02d4ebe1a0fe89fcce536632ff950a27923716fb36ff2b6c02c9114ef453b21f98f6ef4b96d1b88ac2d7f853e092bdb973 SHA512 f473e7238fee5057140507e7efc9865e99778851f42349ea028f08a44820946dbf08e7f3fc996223ddf7a13edecf79a58042f68b30397ff3c9f0819cc3f2cf22
-MISC metadata.xml 254 BLAKE2B 1392a93224819fb2dcdf8e7842fad36812de4dcee5e7424e55932c71885354ee8e308b407a8c7ff5f22b3fde199c17a83c2fc743f0f56d8d21e92dc5b3a43252 SHA512 ef70b7addb82535bb76effbc086b2e94c868c0eeefd321bed35d554f4117007ff5dba431561b16e90ff42a23011568b877959d9d59eac6c7c59642ed9d46bd91
+EBUILD edac-utils-0.18-r1.ebuild 1199 BLAKE2B 75a6ac217e0af96d69834966fc445d0610d57dbba72bc1a1120339e289236d81fd175869198b7070eb2afe182303b4806ee738782d974365db9b671202926393 SHA512 e50ab6190c9c5ba746eea38f259f9859f0eb8aad2035ce99a2f79b7fd2d7a0dac90da070ce334ffa1757244af0fd7f385b73c76d6ea945614b38ea793d677283
+EBUILD edac-utils-0.18.ebuild 1111 BLAKE2B ba93435dbd30940dedaafb83540e36352ae99b3449a5549a1d09404be9a5ef800e082d457f24d95b430a9f629598fa224f81ab511a34e7eb15307bde34271c17 SHA512 4b2827907f8f45d01a08026a11a8dca5762b7fab6e1a4bd4852a945325714efb1e670c751288d513007584b49256fe7b6721fae9f3457d151aec89b1166d6a7b
+MISC metadata.xml 321 BLAKE2B 2828640a5bcb4f053424e252971d3232a31884ff9ee357dd302a47667da146f4eea8f72f1b0765bec79d34f9b9bbd97ef58874a4f107bcf7329725205010bf42 SHA512 4493bc3bd8f1b3ac3b8b9defe38d1368b9fcd7f54a0556e1d786c92bf30ff485875ac2e1bba65ebd96d9c85dc961b0db682bcd448717bd58853143b9b105b1dd
diff --git a/sys-apps/edac-utils/edac-utils-0.18-r1.ebuild b/sys-apps/edac-utils/edac-utils-0.18-r1.ebuild
new file mode 100644
index 000000000000..b48d523eff5d
--- /dev/null
+++ b/sys-apps/edac-utils/edac-utils-0.18-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
+HOMEPAGE="https://github.com/grondo/edac-utils"
+SRC_URI="https://github.com/grondo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="debug"
+
+DEPEND="sys-fs/sysfsutils"
+RDEPEND="${DEPEND}
+ sys-apps/dmidecode"
+
+src_prepare() {
+ default
+
+ # Needed to refresh libtool and friends to not call CC directly
+ # bug #725540
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ # Dump the inappropriate-for-us bundled init script
+ rm -rf "${ED}/etc/init.d" || die
+
+ # Install our own
+ newinitd "${FILESDIR}"/edac.init edac
+ systemd_dounit "${FILESDIR}"/edac.service
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "There must be an entry for your mainboard in ${EROOT}/etc/edac/labels.db"
+ elog "in case you want nice labels in /sys/module/*_edac/"
+ elog "Run the following command to check whether such an entry is already available:"
+ elog " edac-ctl --print-labels"
+}
diff --git a/sys-apps/edac-utils/edac-utils-0.18.ebuild b/sys-apps/edac-utils/edac-utils-0.18.ebuild
index 86bafa9ff0dc..c4aa0a9e04cf 100644
--- a/sys-apps/edac-utils/edac-utils-0.18.ebuild
+++ b/sys-apps/edac-utils/edac-utils-0.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
HOMEPAGE="https://github.com/grondo/edac-utils"
@@ -17,6 +17,8 @@ RDEPEND="${DEPEND}
sys-apps/dmidecode"
src_prepare() {
+ default
+
sed -i \
-e 's|-Werror||' \
configure || die
@@ -34,13 +36,13 @@ src_install() {
# We don't need this init.d file
# Modules should be loaded by adding them to /etc/conf.d/modules
# The rest is done via the udev-rule
- rm -rf "${D}/etc/init.d"
+ rm -rf "${ED}/etc/init.d" || die
find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
- elog "There must be an entry for your mainboard in /etc/edac/labels.db"
+ elog "There must be an entry for your mainboard in ${EROOT}/etc/edac/labels.db"
elog "in case you want nice labels in /sys/module/*_edac/"
elog "Run the following command to check whether such an entry is already available:"
elog " edac-ctl --print-labels"
diff --git a/sys-apps/edac-utils/files/edac.init b/sys-apps/edac-utils/files/edac.init
new file mode 100644
index 000000000000..23318b37e10c
--- /dev/null
+++ b/sys-apps/edac-utils/files/edac.init
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+command=/usr/bin/edac-ctl
+
+start() {
+ ebegin "Registering edac-utils labels"
+ /usr/sbin/edac-ctl --register-labels
+ eend $?
+}
+
+stop() {
+ ebegin "Unregistering edac-utils labels"
+ /usr/sbin/edac-ctl --unload
+ eend $?
+}
diff --git a/sys-apps/edac-utils/files/edac.service b/sys-apps/edac-utils/files/edac.service
new file mode 100644
index 000000000000..b94a4b6b5443
--- /dev/null
+++ b/sys-apps/edac-utils/files/edac.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Initialize EDAC Drivers For Machine Hardware
+
+[Service]
+Type=oneshot
+ExecStart=/usr/sbin/edac-ctl --register-labels
+ExecStop=/usr/sbin/edac-ctl --unload
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/edac-utils/metadata.xml b/sys-apps/edac-utils/metadata.xml
index 0d757f0cc8d4..57f6459cb14b 100644
--- a/sys-apps/edac-utils/metadata.xml
+++ b/sys-apps/edac-utils/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">grondo/edac-utils</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">grondo/edac-utils</remote-id>
+ </upstream>
</pkgmetadata>