summaryrefslogtreecommitdiff
path: root/sys-apps/diffutils
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/Manifest3
-rw-r--r--sys-apps/diffutils/diffutils-3.10_p20250103.ebuild58
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/diffutils/Manifest b/sys-apps/diffutils/Manifest
index d8198c5f60f5..1f933e922161 100644
--- a/sys-apps/diffutils/Manifest
+++ b/sys-apps/diffutils/Manifest
@@ -1,4 +1,7 @@
+DIST diffutils-3.10.242-d65b.tar.xz 1924516 BLAKE2B 3d4a2928b0c9462d1cd570d31b5d8ba32f3c3db23c2f96aca53c55a5d0738ee38ebd412138247313e7dc540284c2243ab49bffd23ed7eb320cef39118f195a2a SHA512 ad27490d59e77f5f6ca4d3a7d88d0ccbc1727aeded2427fd3bf7d5ecf478f182ae24938dec30f0eba9524cae771aac732ad26193a9a3f5356ab204152fa35423
+DIST diffutils-3.10.242-d65b.tar.xz.sig 833 BLAKE2B 2a7c70105d2d88edca9d771a21d39fba78ed25213fb922a48eae1e37d3eb2c07cce5ac24713cfdb336e1edd0def6f31aa79bac84ecc5a7d4ea80b4094cfccb26 SHA512 8a0564e14131c01aa93163a026fe9f87a2bebf4d9354b757233a1af81d7e276fb2e0dbc15e0d95ba89315a33d9751badd641755c901daa531d05547f4bcc9fb0
DIST diffutils-3.10.tar.xz 1624240 BLAKE2B 24a90162b3d876e6378243f19a85a1f1bb4cdfe98d130dee684740a902f2987509d5830dd32df4e26678b468b96960f6f9785ffb922e828cb8b4acce0d8587f6 SHA512 219d2c815a120690c6589846271e43aee5c96c61a7ee4abbef97dfcdb3d6416652ed494b417de0ab6688c4322540d48be63b5e617beb6d20530b5d55d723ccbb
DIST diffutils-3.10.tar.xz.sig 833 BLAKE2B 06650838d6a3327fda6b2ab09693170ec18b730b1f5981c8f3e2180b2c8a553307ae93199e4be0532a534a8a3f95e4a7b4fccbbd9e5f8d1b1cedd0816b0aac90 SHA512 91aa1fcfca224454e292540ea7813f4a0eb348f06a4374017326d524949775359fc833de597cc201c97f357eb6c675800828a6e3332572376f3554f1f2e1aca1
EBUILD diffutils-3.10.ebuild 1664 BLAKE2B ebbccd0e9c7ebf06a925d30128bd8343cab3a30bc189811ec63fe3a9ab6fe29b015e3c86ded1c81660d502cf600a47fa5f09339bca748702f6db04d67d2aefc9 SHA512 1c51fda1f727bda5f89f3423ed892f7bb3edb1d84e8dcdc6fc95a755770a41c06cd8faa3be015fcb4f719223b295cbb79e789277bcdb74270e88564aa0db3cb4
+EBUILD diffutils-3.10_p20250103.ebuild 1673 BLAKE2B 740f235691bf16612e95dfed728316c3193f685ba8a13c0504bc3dcd815c55b6aca89675c66f2a4ba4c4867c0eb3a138e708caf3324bd64ab102340a7a6a883a SHA512 657e1524a31f554873fe21ae2ad35c0d5ef0125c083bdcf2687082454c2d385a70daf080d6a0b2f8137b9b24778bd2711d05eacacd6a42db60eb8aeab386aa68
MISC metadata.xml 403 BLAKE2B 009b73d59702ec89a6dc4e9ff8886ee77f0390961ea51aa5248d6f2fa3c9de0dd7fc8ba6844b0e38b7bae348dbb3b38cc8447f27371127976a5e5ae37aebbb34 SHA512 c0450fc2991ef0b1b56076a82fe88a8c860ac2a11aa78ac86cbaa29b049fdc6c69e11f9da3e9f90501f0a9567884e0bc47cf2b3b0a486cd173d1060b19f04a25
diff --git a/sys-apps/diffutils/diffutils-3.10_p20250103.ebuild b/sys-apps/diffutils/diffutils-3.10_p20250103.ebuild
new file mode 100644
index 000000000000..069dd2e31342
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-3.10_p20250103.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/diffutils.asc
+inherit verify-sig
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="https://www.gnu.org/software/diffutils/"
+
+if [[ ${PV} == *_p* ]] ; then
+ # Subscribe to the 'platform-testers' ML to find these.
+ # Useful to test on our especially more niche arches and report issues upstream.
+ MY_COMMIT="242-d65b"
+ MY_P=${PN}-$(ver_cut 1-2).${MY_COMMIT}
+ SRC_URI="https://meyering.net/diff/${MY_P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://meyering.net/diff/${MY_P}.tar.xz.sig )"
+ S="${WORKDIR}"/${MY_P}
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-diffutils )
+"
+
+src_prepare() {
+ default
+
+ # Needed because of ${P}-diff-D-option-regression.patch
+ #touch man/diff.1 || die
+}
+
+src_configure() {
+ # Disable automagic dependency over libsigsegv; see bug #312351.
+ export ac_cv_libsigsegv=no
+
+ # required for >=glibc-2.26, bug #653914
+ use elibc_glibc && export gl_cv_func_getopt_gnu=yes
+
+ local myeconfargs=(
+ # Interferes with F_S (sets F_S=2)
+ --disable-gcc-warnings
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}