summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/cpuid-20220927.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpuid/cpuid-20220927.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20220927.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20220927.ebuild b/sys-apps/cpuid/cpuid-20220927.ebuild
new file mode 100644
index 000000000000..0f77190b474c
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20220927.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}