summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/cpuid-20180519.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpuid/cpuid-20180519.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20180519.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20180519.ebuild b/sys-apps/cpuid/cpuid-20180519.ebuild
new file mode 100644
index 000000000000..045dbac2f81e
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20180519.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+DEPEND="app-arch/gzip"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=(
+ "${FILESDIR}/${P}-add-spec-ctrl-output.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}