summaryrefslogtreecommitdiff
path: root/sys-apps/colorized-logs/colorized-logs-2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/colorized-logs/colorized-logs-2.5.ebuild')
-rw-r--r--sys-apps/colorized-logs/colorized-logs-2.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-apps/colorized-logs/colorized-logs-2.5.ebuild b/sys-apps/colorized-logs/colorized-logs-2.5.ebuild
new file mode 100644
index 000000000000..36e9589ea6be
--- /dev/null
+++ b/sys-apps/colorized-logs/colorized-logs-2.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="Tools for logs with ANSI color"
+HOMEPAGE="https://github.com/kilobyte/colorized-logs/"
+SRC_URI="https://github.com/kilobyte/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+ # Rename to not collide with dev-python/ansi2html
+ mv "${ED}/usr/bin/ansi2html" "${ED}/usr/bin/cl-ansi2html" || die
+ mv "${ED}/usr/share/man/man1/ansi2html.1" "${ED}/usr/share/man/man1/cl-ansi2html.1" || die
+}