summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 19eb891b560f..8297592e5309 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -141,6 +141,14 @@ src_configure() {
busybox_config_option n FEATURE_VI_REGEX_SEARCH
fi
+ # Disable standalone shell mode when using make-symlinks, else Busybox calls its
+ # applets by default without looking up in PATH.
+ # This also enables users to disable a builtin by deleting the corresponding symlink.
+ if use make-symlinks; then
+ busybox_config_option n FEATURE_PREFER_APPLETS
+ busybox_config_option n FEATURE_SH_STANDALONE
+ fi
+
# If these are not set and we are using a uclibc/busybox setup
# all calls to system() will fail.
busybox_config_option y ASH