summaryrefslogtreecommitdiff
path: root/sys-apps/bolt/bolt-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bolt/bolt-0.9.ebuild')
-rw-r--r--sys-apps/bolt/bolt-0.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/bolt/bolt-0.9.ebuild b/sys-apps/bolt/bolt-0.9.ebuild
new file mode 100644
index 000000000000..f9decd2321f0
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ keepdir /var/lib/boltd
+}