summaryrefslogtreecommitdiff
path: root/sci-visualization/tensorboard
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/tensorboard')
-rw-r--r--sci-visualization/tensorboard/Manifest2
-rw-r--r--sci-visualization/tensorboard/tensorboard-1.15.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 4f8138e3d616..808ec46071e9 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1,5 +1,7 @@
DIST tensorboard-1.13.1.zip 3187614 BLAKE2B e1b8cb43f7941b843e4fa8c84746f4b341e7c7e246422182eec9e1d3e2a5c367fb818c8e3ddd20cb6b5f64515a986dc5e814728340f0592d346dc55ec6065648 SHA512 d1581b7f694909e94a09d4c3fb2d34ddc31a18a6a09323ef48221e88560a9ec3bbb050ff12a2cd78607a2545053cabc448eab7264036a54dddc4720becfc44b3
DIST tensorboard-1.14.0.zip 3149160 BLAKE2B 85a3544c2274757cdfb99e3d82751082415d9283a68808de50c4b14662542bd278db3320560cb39aee6bb62d1434dedfa720cfc83b7d464d99256cfe46081f78 SHA512 b19856b1c252b22e472efb9b91ea5c4509d0c3a9d5f99071dea04325e2346b37967b0be151227d150cf013aee5ae6f6273cd311085f4c6b1ca8021d14c2cf562
+DIST tensorboard-1.15.0.zip 3765194 BLAKE2B 54a9987b65d4e2b127789f0e66eb5bdef8c024d19a82867632b44eefc4718bc6eb6c68fa61fdb2306af2c3adbacc3c75ec15f7aa331038b15cec27af2d846f85 SHA512 7b47d60929b4be91b4d56e36fc5a19b79511b8f3a1081fe308d3a107f978f2c5d23ad2d209104de983bc44f4506cdb0cb6e09b37e552dc042600ea16e14827dc
EBUILD tensorboard-1.13.1.ebuild 1709 BLAKE2B 77ed22515d805d87ced976128fb1437a050317e9522e0fcffdadca46aa224a27f6eb7bb65132332405bca07b8ace3b77b3eb43f0245c4ce5e8c95a5884de156f SHA512 48c270dca6bedd6b37aff0519270d96f5b991645ec2a95ac963cc7ff13a1c62d393c81a79ddf503d4655ef5f236936b32dfcc64e54d826f202d96bb75883ecdd
EBUILD tensorboard-1.14.0.ebuild 1755 BLAKE2B babc76e17559a0af994038d1fd1fece08955617b17059b2f6f69b6ae010f64993deaf267c69830bf2a22dce15f4c53f6caf39bb3da198ab700ac45862ec00377 SHA512 ab3673346dfb5b1e94f8322c99c840bc7b08f07778fb15e19b4dc7cd850d9561091751c9cbb5b7b5b37be97d570dd95ec6f2904984c09eca627016edb12fbba6
+EBUILD tensorboard-1.15.0.ebuild 1755 BLAKE2B babc76e17559a0af994038d1fd1fece08955617b17059b2f6f69b6ae010f64993deaf267c69830bf2a22dce15f4c53f6caf39bb3da198ab700ac45862ec00377 SHA512 ab3673346dfb5b1e94f8322c99c840bc7b08f07778fb15e19b4dc7cd850d9561091751c9cbb5b7b5b37be97d570dd95ec6f2904984c09eca627016edb12fbba6
MISC metadata.xml 494 BLAKE2B 367959e934fdf8e447da9632a05ea0ada6116a7c39cf42096a3b24f0dcf0c0bfbd3263e6f3913611c27e76f629b77d1e5022fa124d7e79f03a224bd3627bb538 SHA512 b59bedcac4e07ddbb62e90df57670116ba51c3d8c6294679ba5d8f17d7adbf3644f3d203c1d1ef4fa06d7e50640148ee259a081afb807477784350b98c52da11
diff --git a/sci-visualization/tensorboard/tensorboard-1.15.0.ebuild b/sci-visualization/tensorboard/tensorboard-1.15.0.ebuild
new file mode 100644
index 000000000000..7c8540d2dd19
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-1.15.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-r1 python-utils-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}