summaryrefslogtreecommitdiff
path: root/sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild')
-rw-r--r--sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild37
1 files changed, 20 insertions, 17 deletions
diff --git a/sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild b/sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild
index 3b95c16cf526..19ccf287fd22 100644
--- a/sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild
+++ b/sci-visualization/quickplot/quickplot-1.0.1_rc.ebuild
@@ -1,49 +1,52 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils
+inherit autotools desktop
MY_P=${P/_rc/rc}
DESCRIPTION="A fast interactive 2D plotter"
-HOMEPAGE="http://quickplot.sourceforge.net/ https://github.com/lanceman2/quickplot"
+HOMEPAGE="
+ http://quickplot.sourceforge.net/
+ https://github.com/lanceman2/quickplot"
SRC_URI="https://github.com/lanceman2/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
-SLOT="0"
LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
RDEPEND="
- media-libs/libsndfile
+ media-libs/libsndfile:=
>=sys-libs/readline-0.6.2:0=
x11-libs/gtk+:3"
-DEPEND="${RDEPEND}
- media-gfx/imagemagick
+DEPEND="${RDEPEND}"
+BDEPEND="
+ media-gfx/imagemagick[png]
virtual/pkgconfig
www-client/lynx"
-S="${WORKDIR}/${PN}-${MY_P}"
+PATCHES=( "${FILESDIR}"/${P}-automake.patch )
src_prepare() {
- sed -i \
- -e '/libquickplot_la_LIBADD/s:$: -lm:g' \
- -e 's/ $(htmldir)/ $(DESTDIR)$(htmldir)/g' \
- Makefile.am || die
default
eautoreconf
}
src_configure() {
econf \
- --enable-developer \
- $(use_enable static-libs static)
+ --disable-static \
+ --enable-developer
}
src_install() {
default
+
make_desktop_entry 'quickplot --no-pipe' Quickplot quickplot Graphics
- mv "${ED%/}"/usr/share/applications/quickplot{*,}.desktop || die
+ mv "${ED}"/usr/share/applications/quickplot{*,}.desktop || die
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}