summaryrefslogtreecommitdiff
path: root/sci-visualization/opendx/opendx-4.4.4-r7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/opendx/opendx-4.4.4-r7.ebuild')
-rw-r--r--sci-visualization/opendx/opendx-4.4.4-r7.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-visualization/opendx/opendx-4.4.4-r7.ebuild b/sci-visualization/opendx/opendx-4.4.4-r7.ebuild
index 024c2706ae3c..1184182477b3 100644
--- a/sci-visualization/opendx/opendx-4.4.4-r7.ebuild
+++ b/sci-visualization/opendx/opendx-4.4.4-r7.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MYP=dx-${PV}
-inherit autotools eutils flag-o-matic
+inherit autotools desktop flag-o-matic
DESCRIPTION="3D data visualization tool"
HOMEPAGE="http://www.opendx.org/"
@@ -48,6 +48,7 @@ PATCHES=(
"${FILESDIR}/${P}-szip.patch"
"${FILESDIR}/${P}-null.patch"
"${FILESDIR}/${P}-invalid-conversion.patch"
+ "${FILESDIR}/${P}-slibtool.patch"
"${WORKDIR}/${PN}-4.4.4_p20160917-fix-c++14.patch"
)
@@ -61,6 +62,9 @@ src_configure() {
# with gcc 3.3.2 I had an infinite loop on src/exec/libdx/zclipQ.c
append-flags -fno-strength-reduce
+ # bug #786627
+ append-cppflags -std=c++14
+
# (#82672)
filter-flags -finline-functions
replace-flags -O3 -O2