summaryrefslogtreecommitdiff
path: root/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild')
-rw-r--r--sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild b/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild
new file mode 100644
index 000000000000..87d8aedc3a92
--- /dev/null
+++ b/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Plotly Dash apps from within Jupyter environments"
+HOMEPAGE="https://plotly.com/dash/"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/ansi2html[${PYTHON_USEDEP}]
+ sci-visualization/dash[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/retrying[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+src_install () {
+ distutils-r1_src_install
+ mv "${D}"/usr/etc "${D}"/ || die
+}