summaryrefslogtreecommitdiff
path: root/sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch')
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch b/sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch
new file mode 100644
index 000000000000..405a2552f08b
--- /dev/null
+++ b/sci-visualization/gwyddion/files/gwyddion-2.55-automagic.patch
@@ -0,0 +1,33 @@
+diff -ruN gwyddion-2.55.orig/configure.ac gwyddion-2.55/configure.ac
+--- gwyddion-2.55.orig/configure.ac 2019-11-04 10:25:16.000000000 +0100
++++ gwyddion-2.55/configure.ac 2020-01-24 05:22:15.264763441 +0100
+@@ -634,21 +634,25 @@
+ #############################################################################
+ # OpenEXR
+ # Optional. Used for HDR greyscale OpenEXR pixmap import/export.
+-enable_exr=$have_cxx
+-PKG_CHECK_MODULES(EXR, [OpenEXR],
++GWY_WITH([exr],,[build with OpenEXR support])
++if test "x$enable_exr" != "xno" && "x$have_cxx" != "xno"; then
++ PKG_CHECK_MODULES(EXR, [OpenEXR],
+ [AC_DEFINE(HAVE_EXR,1,
+ [Define if we have the OpenEXR package.])],
+ [enable_exr=no])
++fi
+ AM_CONDITIONAL([HAVE_EXR],[test "x$enable_exr" != xno])
+
+ #############################################################################
+ # CFITSIO
+ # Optional. Used for FITS image import.
+-enable_cfitsio=yes
+-PKG_CHECK_MODULES(CFITSIO, [cfitsio],
++GWY_WITH([cfitsio],,[build with cfitsio support])
++if test "x$enable_cfitsio" != "xno"; then
++ PKG_CHECK_MODULES(CFITSIO, [cfitsio],
+ [AC_DEFINE(HAVE_CFITSIO,1,
+ [Define if we have the cfitsio package.])],
+ [enable_cfitsio=no])
++fi
+ AM_CONDITIONAL([HAVE_CFITSIO],[test "x$enable_cfitsio" != xno])
+
+ #############################################################################