summaryrefslogtreecommitdiff
path: root/sci-physics/vmc/vmc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/vmc/vmc-9999.ebuild')
-rw-r--r--sci-physics/vmc/vmc-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-physics/vmc/vmc-9999.ebuild b/sci-physics/vmc/vmc-9999.ebuild
index 3598fb0ec8c0..cf26fb07595b 100644
--- a/sci-physics/vmc/vmc-9999.ebuild
+++ b/sci-physics/vmc/vmc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,11 +20,11 @@ HOMEPAGE="https://vmc-project.github.io/ https://github.com/vmc-project/vmc"
LICENSE="GPL-3"
SLOT="0"
-IUSE="c++11 c++14 +c++17 doc"
+IUSE="c++14 +c++17 doc"
-REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+REQUIRED_USE="^^ ( c++14 c++17 )"
-RDEPEND=">=sci-physics/root-6.18:=[c++11?,c++14?,c++17?,-vmc]"
+RDEPEND="sci-physics/root:=[c++14?,c++17?,-vmc(-)]"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
@@ -33,8 +33,7 @@ DOCS=(README.md History)
src_compile() {
cmake_src_compile
if use doc; then
- # TRAVIS_BUILD_DIR hardcoded in Doxyfile by upstream.
- TRAVIS_BUILD_DIR="${S}" doxygen doc/doxygen/Doxyfile || die
+ doxygen doc/doxygen/Doxyfile || die
fi
}