summaryrefslogtreecommitdiff
path: root/sci-physics/root/root-6.26.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root/root-6.26.9999.ebuild')
-rw-r--r--sci-physics/root/root-6.26.9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-physics/root/root-6.26.9999.ebuild b/sci-physics/root/root-6.26.9999.ebuild
index 246be36df972..c1dddda91e80 100644
--- a/sci-physics/root/root-6.26.9999.ebuild
+++ b/sci-physics/root/root-6.26.9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake cuda elisp-common fortran-2 python-single-r1 toolchain-funcs
@@ -18,7 +18,8 @@ IUSE="+X aqua +asimage c++14 +c++17 cuda cudnn +davix debug emacs
mpi mysql odbc +opengl oracle postgres pythia6 pythia8 +python
qt5 R +roofit +root7 shadow sqlite +ssl +tbb test +tmva +unuran uring
vc +xml xrootd"
-RESTRICT="!test? ( test )"
+RESTRICT="test"
+PROPERTIES="test_network"
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
@@ -30,6 +31,7 @@ if [[ ${PV} =~ "9999" ]] ; then
EGIT_BRANCH="v$(ver_cut 1)-$(ver_cut 2)-00-patches"
fi
else
+ SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
fi