summaryrefslogtreecommitdiff
path: root/sci-physics/heppdt
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/heppdt')
-rw-r--r--sci-physics/heppdt/Manifest5
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01-r1.ebuild57
-rw-r--r--sci-physics/heppdt/metadata.xml17
3 files changed, 79 insertions, 0 deletions
diff --git a/sci-physics/heppdt/Manifest b/sci-physics/heppdt/Manifest
new file mode 100644
index 000000000000..90a94549cec0
--- /dev/null
+++ b/sci-physics/heppdt/Manifest
@@ -0,0 +1,5 @@
+DIST HepPDT-3.04.01.tar.gz 1851879 SHA256 2c1c39eb91295d3ded69e0d3f1a38b1cb55bc3f0cde37b725ffd5d722f63c0f6 SHA512 33a93b7d18c0cc64ab13923eb5edca89ed753a7f888a31c1d6a5f84f735e4042e2eaaf04e221d487976603a40fbd84cede4b4dd2bcd2e7479d97cc637dda637b WHIRLPOOL 211e9e8839e508f9929d9f69d9d1d67e633067f5957e5f59f44db6a261d3b515b7d0d9aaf49a9648ee38106ba9b9ea91abdc24820798e678eb79c640456c92ba
+EBUILD heppdt-3.04.01-r1.ebuild 1177 SHA256 7ebca96006ba628a52b2b52608f4a793c2300426bfe58736a4eb1e2f8b9f83ca SHA512 f273e3e200b4f44711947ef943c91badc1da00662c19bf7e55adafe1e1648c934c9a80547179fbd0da8c8f2fb925c9782614ddcd4f1a58ca3c2dc85ca2d9269b WHIRLPOOL 332cdff5a0825f415217f846d705dfe30d3a7e5ee907d8a51cd88ec7bbd8dc3abbc0951b5d0882c88c3357a489e8288209b1d438e3f25bfd3d43ba3e7dd5c19e
+MISC ChangeLog 2951 SHA256 3348f5e1192cbb16a6a35c1c01732161ae67b62ee2cc3123ddc9115786531951 SHA512 3a2821e8de9443ce8b0c74123367bef0f22a16e14b0601f9ed47fb068a8d83603bf26a7c08f120f66fd847fd33bcf82ea8d3bff3b0e31ea415fd1c4fd0556f2e WHIRLPOOL 4a61a1878ade8383ecd349ba3ea6471c9edbdf7d7300f2c6097ff71355116e8217cb34943dec2063c20a06a3109d541b8850e0ec924732f90088193fc16edad2
+MISC ChangeLog-2015 741 SHA256 89bb86418a732729e732f2a0d452e788732a671ba350790dbdb31a16f86a8006 SHA512 a80774ad9f02350201a8ade6a5c27ea75ffc7c991de4b119f5163f1e591933e12da1b6165aa6113860733407732d65c40b226afde2eb1581819ac145077c0193 WHIRLPOOL f3113a2d4eba38260f876f8b1cc0173e4f179980f7626e9a2ae5d6b237b02b1d3ff8c204d0f559f25cdfe5c1d7e0a6a66a7246ca3e2ea2f7f1290570677d4c9a
+MISC metadata.xml 723 SHA256 5b5af3fc7925e5f1c97ddf55ec2162405f5e6d75f40e9eb2ee3114a71aee1dad SHA512 3dc66e18e8d7df29f7b298e4e9e2e3f3944194cd48062f15250fd174c08cc8a812c9656bcfec02435a6d78056da6b6522527f1f5a951fd41a12c5a2f701919d5 WHIRLPOOL 29824b04875e33a408415fb339ea3e602082aac66beac90ae7960848ce8a476326bc35fbf4f7ba994887c7ff27a8bbbc92ab8eea63b7e0977be3aa35665f2103
diff --git a/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild b/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild
new file mode 100644
index 000000000000..e5ec556641c7
--- /dev/null
+++ b/sci-physics/heppdt/heppdt-3.04.01-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P=HepPDT-${PV}
+
+DESCRIPTION="Data about each particle from the Review of Particle Properties"
+HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepPDT/"
+SRC_URI="${HOMEPAGE}/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # respect user flags
+ sed -i \
+ -e '/AC_SUBST(AM_CXXFLAGS)/d' \
+ configure.ac || die
+ # directories
+ sed -i \
+ -e 's:$(prefix)/data:$(datadir)/${PN}:g' \
+ data/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/src/HepPDT:${S}/src/HepPID" \
+ emake check MY_LD=-L SHEXT=so
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ mv "${ED%/}"/usr/doc/* "${ED%/}"/usr/share/doc/${PF}/ || die
+ fi
+ if use examples; then
+ mv "${ED%/}"/usr/examples "${ED%/}"/usr/share/doc/${PF}/ || die
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ rm -rf "${ED%/}"/usr/{doc,examples} || die
+}
diff --git a/sci-physics/heppdt/metadata.xml b/sci-physics/heppdt/metadata.xml
new file mode 100644
index 000000000000..f34cc770d951
--- /dev/null
+++ b/sci-physics/heppdt/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+</maintainer>
+<longdescription lang="en">
+ HepPDT contains the fixed data about each particle type. In other
+ words, it contains the data that can be found in the Review of
+ Particle Properties.
+ This data is conceptually split into particle information (e.g. mass)
+ and decay information. HepPDT provides a simple set of particle data
+ classes. Particle ID translation methods are in a separate HepPID
+ library, which is distributed as part of HepPDT.
+</longdescription>
+</pkgmetadata>