summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc/hepmc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/hepmc/hepmc-9999.ebuild')
-rw-r--r--sci-physics/hepmc/hepmc-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/sci-physics/hepmc/hepmc-9999.ebuild b/sci-physics/hepmc/hepmc-9999.ebuild
index cb2ff090e84d..788d8d48adf5 100644
--- a/sci-physics/hepmc/hepmc-9999.ebuild
+++ b/sci-physics/hepmc/hepmc-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake python-single-r1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit fortran-2 cmake python-single-r1
MYP=HepMC3-${PV}
@@ -26,7 +26,14 @@ IUSE="doc test examples python root"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
DEPEND="${RDEPEND}"
BDEPEND="
root? ( sci-physics/root:= )
@@ -52,5 +59,5 @@ src_configure() {
src_install() {
cmake_src_install
use examples && docompress -x /usr/share/doc/${PF}/examples
- python_optimize
+ use python && python_optimize
}