summaryrefslogtreecommitdiff
path: root/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/geant4_vmc/geant4_vmc-9999.ebuild')
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-9999.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
index 9ad9d152375f..13017563cf1f 100644
--- a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
+++ b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,20 +20,20 @@ HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
LICENSE="GPL-3"
SLOT="4"
-IUSE="doc examples geant3 +g4root +mtroot vgm test"
+IUSE="doc examples geant3 +g4root vgm test"
RDEPEND="
sci-physics/geant[c++17,opengl,geant3?]
- sci-physics/root:=[c++17,-vmc]
+ sci-physics/root:=[c++17,-vmc(-)]
sci-physics/vmc:=[c++17]
vgm? ( sci-physics/vgm:= )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( >=sci-physics/geant-4.11[gdml] )"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
RESTRICT="
!examples? ( test )
!geant3? ( test )
!g4root? ( test )
- !mtroot? ( test )
!test? ( test )
!vgm? ( test )"
@@ -44,9 +44,9 @@ src_configure() {
-DGeant4VMC_USE_VGM="$(usex vgm)"
-DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
-DGeant4VMC_USE_G4Root="$(usex g4root)"
- -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
-DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
-DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ -DGeant4VMC_BUILD_G4Root_TEST="$(usex test)"
)
cmake_src_configure
}
@@ -57,14 +57,11 @@ src_compile() {
local dirs=(
source
$(usev g4root)
- $(usev mtroot)
$(usev examples)
)
local d
for d in "${dirs[@]}"; do
- pushd "${d}" > /dev/null || die
- doxygen || die
- popd > /dev/null || die
+ doxygen "${d}"/Doxyfile || die
done
fi
}