summaryrefslogtreecommitdiff
path: root/sci-ml
diff options
context:
space:
mode:
Diffstat (limited to 'sci-ml')
-rw-r--r--sci-ml/Manifest.gzbin4568 -> 4568 bytes
-rw-r--r--sci-ml/huggingface_hub/Manifest2
-rw-r--r--sci-ml/huggingface_hub/huggingface_hub-0.28.1.ebuild75
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-ml/Manifest.gz b/sci-ml/Manifest.gz
index c1da459c2652..9a27e1489a68 100644
--- a/sci-ml/Manifest.gz
+++ b/sci-ml/Manifest.gz
Binary files differ
diff --git a/sci-ml/huggingface_hub/Manifest b/sci-ml/huggingface_hub/Manifest
index f87ac3f77707..1bd6e3bf3a24 100644
--- a/sci-ml/huggingface_hub/Manifest
+++ b/sci-ml/huggingface_hub/Manifest
@@ -1,3 +1,5 @@
DIST huggingface_hub-0.27.1.gh.tar.gz 4079456 BLAKE2B 846291aa9242e6951c26fd8f695a2f324899b473e01a582dc0fa9aad11e0bb30233761c5dd573876167913e4fe89c2616ab857892c08fa067eac11d7b2fb5228 SHA512 64d435a08765c67e3046370a4bc701da136570f3b23cdf1b5d35c679331694c8cb35ece72417f34f4288d035695d39e4ab6e1e1dce2fb33db42b3664258186cd
+DIST huggingface_hub-0.28.1.gh.tar.gz 6559176 BLAKE2B 30c465d7e844dadf4d3154bdb440bcac4296860518e38ae607994e5f7e6642c2e2b94d755faf48e2d129f621275df55819903723113f1bd76bbd3b61c0f49dcc SHA512 3893cac7540d0cc8be65047c1b6798f3d39592070a9be5a86b5f44464cc66d2f12b2a3f0c5c5a12b96a624f128e1160bda1c45c814d2acae294f1484929ec11c
EBUILD huggingface_hub-0.27.1.ebuild 2090 BLAKE2B aaf70ecfc27fd13a534de3d721c2a3b21269452328a68463c3666b1a1434b9ac2b63930c435a26c06a5b628774b99835fba3f60f2eada150ee95b53a1b37b541 SHA512 d2b2cd492dea1f3cf35a1b6922d6f36f8518af54d6fc858c9c979285a812beb0463c1900bffe78508ed83481e0c010adaff920940b112072a43ecffd386360ed
+EBUILD huggingface_hub-0.28.1.ebuild 2040 BLAKE2B 37fb0318339fa62812a3d7f2e53816e436624916949bbead2641dc4c01e2feab8273ff39a947e1824295ea7792fe025b9f67df61d37665580be817d3b1d3db50 SHA512 b1476ccc23d3904b903edfdbc3671793a607d5f2c5eba669aa3ec83b23d67774f21f34d183bd992d3c99785a5f6ded48e55c64cc04fe699758adc5e22c99f614
MISC metadata.xml 393 BLAKE2B 1703224359804943e921acb978be119c5ae48c6dae23177d9ba2a4b843a1f8cf10487c7dfc5af83600bb98f1443cb5d3cdad1d48ddc5db7117ebb3092af5fe44 SHA512 74ac25236d7cd4b169ec6281480b140e25f0b2579998ca441eb2ab5c070ed87690c49b7af1bb7b83d8782685c18dc3d2cd5f7ef27e8a51fa8863badc58214461
diff --git a/sci-ml/huggingface_hub/huggingface_hub-0.28.1.ebuild b/sci-ml/huggingface_hub/huggingface_hub-0.28.1.ebuild
new file mode 100644
index 000000000000..292c7542bfa7
--- /dev/null
+++ b/sci-ml/huggingface_hub/huggingface_hub-0.28.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="test? (
+ sci-ml/pytorch[${PYTHON_SINGLE_USEDEP}]
+ dev-vcs/git-lfs
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ contrib/sentence_transformers/test_sentence_transformers.py
+ contrib/spacy/test_spacy.py
+ contrib/timm/test_timm.py
+ tests/test_cache_layout.py
+ tests/test_cache_no_symlinks.py
+ tests/test_command_delete_cache.py
+ tests/test_commit_scheduler.py
+ tests/test_file_download.py
+ tests/test_hf_api.py
+ tests/test_hf_file_system.py
+ tests/test_inference_api.py
+ tests/test_inference_async_client.py
+ tests/test_inference_client.py
+ tests/test_inference_text_generation.py
+ tests/test_repocard.py
+ tests/test_repository.py
+ tests/test_snapshot_download.py
+ tests/test_utils_cache.py
+ tests/test_utils_http.py
+ tests/test_utils_telemetry.py
+ tests/test_webhooks_server.py
+ )
+
+ local EPYTEST_DESELECT=(
+ tests/test_dduf.py::TestExportFolder::test_export_folder
+ tests/test_hub_mixin.py::HubMixinTest::test_push_to_hub
+ tests/test_hub_mixin_pytorch.py::PytorchHubMixinTest::test_push_to_hub
+ tests/test_offline_utils.py::test_offline_with_timeout
+ tests/test_utils_pagination.py::TestPagination::test_paginate_github_api
+ )
+
+ distutils-r1_src_test
+}