summaryrefslogtreecommitdiff
path: root/sci-misc
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/Manifest.gzbin2576 -> 2576 bytes
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest2
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.2.1.1.ebuild110
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-misc/Manifest.gz b/sci-misc/Manifest.gz
index 6600c7795175..5ded37adad59 100644
--- a/sci-misc/Manifest.gz
+++ b/sci-misc/Manifest.gz
Binary files differ
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 8330c830b33e..bc87986a3d79 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-desktop-bin-4.1.8.1.rpm 332883125 BLAKE2B e0d46f6eb1718b5f2e2b00b1ac934bfa3bab12b2d5e9c0cafd2874a67cc1fc8a1aabc5ac9d5d3ac4abf53b262a8e5cdc8d27ef4c2cdc30a069420f2227dffed2 SHA512 9a6fa8729c4cab9df7643bbc1c2094e438ff9136b7c2f5897a5e0603ad8740e3ed46b6fe7a01885c063d0df6310dca8fe4aadb45da76c1543841b9eb7d70080d
+DIST jupyterlab-desktop-bin-4.2.1.1.rpm 333190569 BLAKE2B 838b26ab78aaa42b48877b88f19b80617c2f9dc690c4133ec0797422207f8225264d5d891a9b7d65048449e1b27328503934f690cddef966c9a2e0a659c18ca6 SHA512 82f0f096cffd8ae2f154c03d92ea90ba1e60028b3b1a560337281399639eee78945e37ac158a1e661baeef100c250b089c513949190ab0413bd4aa4276d84f65
EBUILD jupyterlab-desktop-bin-4.1.8.1-r1.ebuild 2828 BLAKE2B 229d198c65a2635ad65bea811464ac0b263cd0802fba4590b60903a9d2ec889035f0c1a22de273703e38f2cca6089acef32ac3a7ff06c838237e583c04b0d5d9 SHA512 3bb370a8343b5cf7123eecf9df7651896c3ea27ed8172643ba5dccac60040831ba65d5eb908fce4fbb90a492f0d16dba7739c0feff73a5abc82c1c23a6bbcad7
+EBUILD jupyterlab-desktop-bin-4.2.1.1.ebuild 2828 BLAKE2B 73f6a115f77e355427013df1e9b83be153954350b672c193a9faa932b71f44de894d618cb4927619e8eabbe30e3792271944444ed84dcc75a01fdddb774e0999 SHA512 b6e56a524f0057c862641171603e423fab41c5b6bdc5ab3831c01947be1149eb33350f20174ab2f60b480ba57815a7b31e549897bae3298846216f927ba41d1a
MISC metadata.xml 430 BLAKE2B 1bd3f621bb4d25086cc80c5b44a7eef4a61f58c1f56c7cb91ca4e39b8a5e7d5fdd37e912e48d99ee6ba6a19de1c61252b4ebe3afd554d487c549d22597c376fc SHA512 b99b088cb0bdcfdaa9d584fb580b12a754f30a378fdede655f7723075e81948fc57f9aad11a59944b164eb8c9c24f6f0828e95c5a227766e985778900ea08079
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.2.1.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.2.1.1.ebuild
new file mode 100644
index 000000000000..ca5796ef53de
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-4.2.1.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora-x64.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL-1.1 CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ >=dev-python/jupyterlab-$(ver_cut 1-3)
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local size=512
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}