summaryrefslogtreecommitdiff
path: root/sci-misc/vitables/vitables-3.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/vitables/vitables-3.0.0-r1.ebuild')
-rw-r--r--sci-misc/vitables/vitables-3.0.0-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/sci-misc/vitables/vitables-3.0.0-r1.ebuild b/sci-misc/vitables/vitables-3.0.0-r1.ebuild
deleted file mode 100644
index a39e483b2048..000000000000
--- a/sci-misc/vitables/vitables-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_P=ViTables-${PV}
-
-DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
-HOMEPAGE="https://vitables.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
- dev-python/pytables[${PYTHON_MULTI_USEDEP}]
- dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
- ')"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- # remove the PyQt5 dependency
- # because PyQt5 in Gentoo does not provide egg-info
- # see also: https://github.com/pyqt/python-qt5/issues/18
- sed "s:'PyQt5 [^ ]*::" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}