summaryrefslogtreecommitdiff
path: root/sci-misc/oww/oww-0.86.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/oww/oww-0.86.5-r1.ebuild')
-rw-r--r--sci-misc/oww/oww-0.86.5-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-misc/oww/oww-0.86.5-r1.ebuild b/sci-misc/oww/oww-0.86.5-r1.ebuild
new file mode 100644
index 000000000000..e91581f01553
--- /dev/null
+++ b/sci-misc/oww/oww-0.86.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A one-wire weather station for Dallas Semiconductor"
+HOMEPAGE="http://oww.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls usb"
+
+RDEPEND="
+ net-misc/curl
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.86.4-build.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-musl.patch
+ "${FILESDIR}"/${P}-c99.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-interactive \
+ $(use_enable nls) \
+ $(use_enable gtk gui) \
+ $(use_with usb)
+}