summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.10.ebuild47
-rw-r--r--sci-mathematics/4ti2/Manifest4
-rw-r--r--sci-mathematics/4ti2/files/4ti2-1.6.10-slibtool.patch78
-rw-r--r--sci-mathematics/Manifest.gzbin19532 -> 19536 bytes
-rw-r--r--sci-mathematics/coq/Manifest6
-rw-r--r--sci-mathematics/coq/coq-8.17.1.ebuild122
-rw-r--r--sci-mathematics/coq/coq-8.19.2.ebuild4
-rw-r--r--sci-mathematics/coq/coq-8.20.0.ebuild4
-rw-r--r--sci-mathematics/why3-for-spark/Manifest2
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2023.12.13-r1.ebuild (renamed from sci-mathematics/why3-for-spark/why3-for-spark-2023.12.13.ebuild)7
10 files changed, 265 insertions, 9 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.10.ebuild b/sci-mathematics/4ti2/4ti2-1.6.10.ebuild
new file mode 100644
index 000000000000..580a2eadbe87
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="https://4ti2.github.io"
+SRC_URI="https://github.com/4ti2/4ti2/releases/download/Release_${PV//./_}/${P}.tar.gz
+ https://dev.gentoo.org/~mjo/distfiles/${P}-musl.patch.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sci-mathematics/glpk:=[gmp]
+ dev-libs/gmp:0=[cxx(+)]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-slibtool.patch"
+ "${WORKDIR}/${P}-musl.patch"
+)
+
+src_prepare() {
+ default
+
+ # The swig subdir is not used on Gentoo, and in 1.6.10, they
+ # actually forgot to ship it. Let's make extra sure that e.g.
+ # we don't waste time autoreconfing it.
+ rm -rf swig || die
+ sed -e '/SUBDIRS += swig/d' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # This is not pointless: configure.ac disables shared libraries and
+ # enables static libraries by default.
+ econf --enable-shared --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-mathematics/4ti2/Manifest b/sci-mathematics/4ti2/Manifest
index 2261eaaf09e0..400dbf505c69 100644
--- a/sci-mathematics/4ti2/Manifest
+++ b/sci-mathematics/4ti2/Manifest
@@ -1,5 +1,9 @@
AUX 4ti2-1.3.2-gold.patch 434 BLAKE2B 38162dea9fa7e7072966fc7c5fc72c05e2d122dbfbb25aa0027f992f0fe23bd1232245c670b8f3d3a2b75e67319a217aead99850ec6d1a025c6c4a890605b2c3 SHA512 109f89dcf1f66fae079d9ba4c265b0a9ad0a60b88848ae38175d98c51b8b8fce3e92b0f862191340f4a8dd8c60a768c77b1504d0a797553b5cd1fe5bc95189ff
+AUX 4ti2-1.6.10-slibtool.patch 3198 BLAKE2B e6785a6deb104aa114624dfdbcf3e7848ed27eac88fa073f246c70dcd7b8b6e21911904def4940c650b874507fe3ab61e3acdcf330c259fa6134ea3cdd29c6b3 SHA512 be2cc10232e08052cda53661d1048dbf833409ea5e7e2707c6183a943d537c0a4aabf2da69e41e67ff61849b782f4377259407456ea8766c577e08f26987c998
AUX 4ti2-1.6.7-gcc13.patch 895 BLAKE2B 2827da0a04f2871af174ffda828aca91141d18f379e30c27c10e3807b369b502ef7ebf781a4137e0c6651e5e7922912857bbf5cd3d24b12c1571828983ba3f63 SHA512 0de85310fd9680ed1f3adc5b4990283d4d6ee2ebf8a8c82e195ad323fcf1cbd16fa3727dc428f26b945edf660285332354a102c19eb37737beabbc5d9cfe9444
+DIST 4ti2-1.6.10-musl.patch.xz 15820 BLAKE2B 2994a4e0e589e8c8233bf9367206129605538145b3dffd6dc186026d0e45d78e382467dbebd13d5e0ae5d4f96a0a9411811d3ddb390b5a9e68e4251bd37fbb02 SHA512 2fd0f470cf5d571875715be3dd67ea05edb222f1ca30f33698f3bfe1c470fa56695b03ccdf27dfaacaa613616cf67bc9165072c710d267be370a718f40a268bd
+DIST 4ti2-1.6.10.tar.gz 5496480 BLAKE2B e6d90e0282c1ad63ee887c7f301ce8127791d1f75b5c8a43866b812e7e773495ee2cf33e1e1d23eb3974cdd0632d7efc61ee7b2029902adad5601c3eedacbced SHA512 d591ed272664c7467e9b28082c0a99002b3a4616cf437eecd243ccca2ab0f08abdba5dcd039a109b05793f7aaf9f405af9a58c7eff90b7b01b3b1f34fb7fdb2e
DIST 4ti2-1.6.7.tar.gz 5649869 BLAKE2B ab0e7da1de88e5e99ead0b8fa7f7a72773b84ae903a31dc3134e83364ea45069889f8ce9812bb471cf72b824fe013756d557489b4d2ab31216141d5b6347acfc SHA512 38d638fe01ff3cef1aebae1eefd276cf02f808978851b4465e132f77d3ab34ea51d512e2ea28a42ac65263b458c43cf420dc5f8ac930f959dd0c14916cef9841
+EBUILD 4ti2-1.6.10.ebuild 1168 BLAKE2B ed74aae750dc6c887785b576aa2067a77a47761bd0e8c18ab252cd0c61a51f8aefbaf68ff4b937a561a379a3360130bf26157f15c5eaa941e0cc47c2e7c5b8f6 SHA512 ceb1a742061be09112307c8535ea63bc56248aed0e9cc7acdb5d080eece2cc6cc8e4254596c09cbfc909a9f5bc7fe52446d9dfd96dacadb90d9ebe09d382cde6
EBUILD 4ti2-1.6.7-r1.ebuild 882 BLAKE2B 53225de86083c1f5f65a65138979c59eef5d460b0b7e5443d25a5e07957d7df61c4f0bb87621cea0a0e0cea754abcad61da66da0418f9b42354ae0b301d3fb5b SHA512 44966dc8c9f8aa40c02bb542dec561b7c658264ec29845933ff92caea50b9a4dd016b57f1c724f22bfde8a0a81a54b9c29485b82bdf369512b687c9f5982169d
MISC metadata.xml 531 BLAKE2B b06d3faf7ccbde8dfc9012e3d4060a703639873b4ebbda9c2fb07ef1fd4e6ad6b97d09e7ed12d8adfd35492c2cdc93ae9290987129e7f0aa34d6b0df6f8513ae SHA512 3564979bae9192cadb2351ec2a401d71de987d78e320701676f8e356a3352b75e921dd807a33e4963687489cd4b9f1dab7112c7d631cb74fef39d3b66943970e
diff --git a/sci-mathematics/4ti2/files/4ti2-1.6.10-slibtool.patch b/sci-mathematics/4ti2/files/4ti2-1.6.10-slibtool.patch
new file mode 100644
index 000000000000..5765fa75d5fb
--- /dev/null
+++ b/sci-mathematics/4ti2/files/4ti2-1.6.10-slibtool.patch
@@ -0,0 +1,78 @@
+mjo: we had another patch in Gentoo that adds "-lgmp" to 4ti2gmp_LDADD.
+I merged it into this one because otherwise they conflict.
+
+From b87d4c02616d6e5218658a782854e3156ab885aa Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Thu, 7 Mar 2024 14:10:14 -0800
+Subject: [PATCH] build: link internal dependencies with .la files
+
+When linking with internal dependencies the correct way is to add the
+libtool archives (.la) files to the appropriate LIBADD or LDADD
+variables.
+
+This fixes a build issue when using slibtool instead of GNU libtool.
+
+Gentoo issue: https://bugs.gentoo.org/916679
+---
+ src/groebner/Makefile.am | 10 +++++-----
+ src/zsolve/Makefile.am | 3 ++-
+ swig/allegrocommonlisp/Makefile.am | 8 ++++----
+ 3 files changed, 11 insertions(+), 10 deletions(-)
+
+diff --git a/src/groebner/Makefile.am b/src/groebner/Makefile.am
+index 64c2780..183920f 100644
+--- a/src/groebner/Makefile.am
++++ b/src/groebner/Makefile.am
+@@ -268,17 +268,17 @@ WRAPPERSCRIPTS = \
+ nodist_bin_SCRIPTS = $(WRAPPERSCRIPTS)
+ DISTCLEANFILES = $(WRAPPERSCRIPTS)
+
+-AM_LDFLAGS = -L../4ti2 -R$(libdir) -l4ti2common -no-undefined
++AM_LDFLAGS = -R$(libdir) -no-undefined
+
+ # 16 bit precision flags.
+-# 4ti2int16_LDADD = lib4ti2int16.la
++# 4ti2int16_LDADD = lib4ti2int16.la $(top_builddir)/src/4ti2/lib4ti2common.la
+ # 4ti2int16_CPPFLAGS = -D_4ti2_INT16_
+ # 4ti2int16_SOURCES = $(4ti2sources)
+ # lib4ti2int16_la_CPPFLAGS = -D_4ti2_INT16_
+ # lib4ti2int16_la_SOURCES = $(lib4ti2sources)
+
+ # 32 bit precision flags.
+-4ti2int32_LDADD = lib4ti2int32.la
++4ti2int32_LDADD = lib4ti2int32.la $(top_builddir)/src/4ti2/lib4ti2common.la
+ 4ti2int32_CPPFLAGS = -D_4ti2_INT32_
+ 4ti2int32_CXXFLAGS = $(TRAPV) $(AM_CXXFLAGS)
+ 4ti2int32_SOURCES = $(4ti2sources)
+@@ -287,7 +287,7 @@ lib4ti2int32_la_CXXFLAGS = $(TRAPV) $(AM_CXXFLAGS)
+ lib4ti2int32_la_SOURCES = $(lib4ti2sources)
+
+ # 64 bit precision flags.
+-4ti2int64_LDADD = lib4ti2int64.la
++4ti2int64_LDADD = lib4ti2int64.la $(top_builddir)/src/4ti2/lib4ti2common.la
+ 4ti2int64_CPPFLAGS = -D_4ti2_INT64_
+ 4ti2int64_CXXFLAGS = $(TRAPV) $(AM_CXXFLAGS)
+ 4ti2int64_SOURCES = $(4ti2sources)
+@@ -298,7 +298,7 @@ lib4ti2int64_la_SOURCES = $(lib4ti2sources)
+ # Arbitrary precision flags.
+ # 4ti2 uses GMP (GLPL), an arbitrary precision arithmetic library.
+ if HAVE_GMP_WITH_CXX
+-4ti2gmp_LDADD = lib4ti2gmp.la
++4ti2gmp_LDADD = lib4ti2gmp.la -lgmp $(top_builddir)/src/4ti2/lib4ti2common.la
+ 4ti2gmp_CPPFLAGS = -D_4ti2_GMP_ $(GMP_CFLAGS)
+ 4ti2gmp_SOURCES = $(4ti2sources)
+ lib4ti2gmp_la_CPPFLAGS = -D_4ti2_GMP_
+diff --git a/src/zsolve/Makefile.am b/src/zsolve/Makefile.am
+index 3a55c40..7826993 100644
+--- a/src/zsolve/Makefile.am
++++ b/src/zsolve/Makefile.am
+@@ -88,7 +88,8 @@ endif
+ # Link in the "common" 4ti2 functions.
+ # -no-undefined declares that no undefined symbols will remain after linking all these libraries.
+ # (This is necessary to build shared libraries on Cygwin.)
+-libzsolve_la_LDFLAGS = -L../4ti2 -R$(libdir) -l4ti2common ${GMP_LIBS} -no-undefined
++libzsolve_la_LDFLAGS = -R$(libdir) ${GMP_LIBS} -no-undefined
++libzsolve_la_LIBADD = $(top_builddir)/src/4ti2/lib4ti2common.la
+
+ bin_SCRIPTS = hilbert graver
+ DISTCLEANFILES = hilbert graver
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index a895f5bcc3fc..62d193508cb2 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index daefd4ddc0dd..22b204260021 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,5 +1,7 @@
+DIST coq-8.17.1.tar.gz 7506035 BLAKE2B 29b5b11666185ec293f50264f5a8ad66433c3ce05d74128b524f6fc3c6810551fe76d11d6f9db7d3741b829ac8bacb66948aad522d0cd2c487692c3df8b563ff SHA512 9a35311acec2a806730b94ac7dceabc88837f235c52a14c026827d9b89433bd7fa9555a9fc6829aa49edfedb24c8bbaf1411ebf463b74a50aeb17cba47745b6b
DIST coq-8.19.2.tar.gz 7678311 BLAKE2B 5f9617fbe0127b0c8357c63f331ba3e9fb5a931be9a4a8e8de2e27820a0d986bf99ed9a512740a0f721c742504225ae56e240af893510aa0e449931499d10aab SHA512 91bc81530fa4f6498961583ad51eac5001f139881788b88e360a866ad8e2a6e2c5bce86d1a580ab4cd4782bf49d48318767df82471ce33ba3ac143e5569ad33c
DIST coq-8.20.0.tar.gz 7839432 BLAKE2B 9b489db0cc6874b0a629f3bdb4b503201005ec95a3375441538cd7e51d371a39561b9d0ab23ac485652782fdc7ae8d90c97ca1ff4d9a85fb8727a39ed4a6f48c SHA512 1a7eac6e2f58724a3f9d68bbb321e4cfe963ba1a5551b9b011db4b3f559c79be433d810ff262593d753770ee41ea68fbd6a60daa1e2319ea00dff64c8851d70b
-EBUILD coq-8.19.2.ebuild 2483 BLAKE2B ce2870e40fe70f113cb52eea1a7b5771bee4180d0a58e4bfb539feb0c499531b2dc1388066f33bb7024d77c5efc8541d3e545e86568e58cec12c48eaa9f8360d SHA512 49605fd89331d80ac24bd886f1b96ffbf9ad17c0ffec3dfe2ac0bda2176853f10e023708a02ccffbcda2c0f2a9443e921a44e2745446ac13181aada4c5aebb97
-EBUILD coq-8.20.0.ebuild 2895 BLAKE2B 537f16925a0b630a4fec48a5503aa3e10a8a225aca594d2cdd529f6ede52bdca5b6139b9556daba827f8283278827a013438ce4b4ce5153c038a01b79b774ac9 SHA512 c24c2a9d573a348ca6934de093b281c84de698b95355714f9d8d7d9d81d1d945eafa869370f9847731e4d930ae10e77600581aa3d27be6cace6adfaaa4f62323
+EBUILD coq-8.17.1.ebuild 2491 BLAKE2B cc88e3c71a041b67cbb100551f78c168111e77c7d8b5e3219331b629af909cc80be4a3ef2651fd1705f37505e5df80de5ae0a802f3e8b33a7fa97cc9d1fbaf0e SHA512 b532cd7cecb6279f077a94ddc3dfb579243361f4d3eeb4690467fd3e79e7e8de43c98b9293264733345ca9e4716edd268e6ad68c344d24d3d46b5b9ea823280f
+EBUILD coq-8.19.2.ebuild 2490 BLAKE2B 256cdcc9dd137a45d00f29b7d3f426231b3da7ea3b83a1f6fc6d7a488b74a3d960bbe64fe9086c9d966e286451f6a5db395d508ca269c5468db36349386b5a92 SHA512 ef1951b26bd3e181b7f496dcd4d083bd4d2a7a72a49b5d7001deaa3e2f148080ff3c40a3fbdfc5feff380ce41df5bb611e71bdd7ebd08a240e0cc963650adecf
+EBUILD coq-8.20.0.ebuild 2902 BLAKE2B f733906f095c446825c9266a9dcd302325a9ea7e516362a7fd99cf6290797660a6a2e500e516544187c046f613076f5b970fd8b55aaf615312620929f7a0379f SHA512 d1d2bd27a3fe7b98bb8dae6bf4dbbeaad8721fa0f0193b23427520c10d6fb642026fd2a9f7f8293363ee9226bf4fa68ef70fdff188b691a8299cfe9f00f4e579
MISC metadata.xml 1047 BLAKE2B 9f6defdf213139ee6549bc8f3b36ce5e8f53ea73bd5aad9262932cbaea7e90bd97c9ffc9dbbd03ac50097c5a6f19f5ddf00dd2b74cc6a5349faf1b597244fb67 SHA512 0f5bfbdd9ffd6f64379e697ed7cf90c2d9257cd1815e520aa14235f1cb399d20fc863221a0cae803cc88e5975be964b9debc3d750a6378ea157146f2e567c5dc
diff --git a/sci-mathematics/coq/coq-8.17.1.ebuild b/sci-mathematics/coq/coq-8.17.1.ebuild
new file mode 100644
index 000000000000..f9f1b9c3cb76
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.17.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+inherit check-reqs desktop dune edo
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/
+ https://github.com/coq/coq/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug doc gui +ocamlopt test"
+
+# TODO: Lots of failing tests. Maybe investigate later.
+# RESTRICT="!test? ( test )"
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/num:=
+ dev-ml/zarith:=
+ gui? (
+ >=dev-ml/lablgtk-3.1.2:3=[sourceview,ocamlopt?]
+ >=dev-ml/lablgtk-sourceview-3.1.2:3=[ocamlopt?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-ml/findlib
+ doc? (
+ >=dev-java/antlr-4.7:4
+ dev-python/antlr4-python3-runtime
+ dev-python/beautifulsoup4
+ dev-python/pexpect
+ dev-python/sphinx-rtd-theme
+ dev-python/sphinxcontrib-bibtex
+ dev-tex/latexmk
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ media-fonts/freefont
+ )
+ test? (
+ dev-ml/ounit2
+ )
+"
+
+CHECKREQS_DISK_BUILD="2G"
+
+DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+DUNE_PACKAGES=()
+
+src_prepare() {
+ # Remove failing tests. bug #904186
+ rm -r test-suite/coq-makefile/timing || die
+
+ default
+}
+
+src_configure() {
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+
+ DUNE_PACKAGES=(
+ coq-core
+ coq-stdlib
+ coqide-server
+ coq
+ )
+ use gui && DUNE_PACKAGES+=( coqide )
+
+ emake clean
+
+ local -a myconf=(
+ -prefix /usr
+ -libdir "/usr/$(get_libdir)/coq"
+ -mandir /usr/share/man
+ -docdir "/usr/share/doc/${PF}"
+ -datadir /usr/share/coq
+ -configdir "/etc/xdg/${PN}"
+ -native-compiler "$(usex ocamlopt yes no)"
+ )
+ use debug && myconf+=( -debug )
+ edo sh ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake DUNEOPT="--display=short --profile release" VERBOSE=1 dunestrap
+
+ dune-compile "${DUNE_PACKAGES[@]}"
+
+ use doc && emake refman-html
+}
+
+src_install() {
+ dune-install "${DUNE_PACKAGES[@]}"
+
+ if use gui ; then
+ make_desktop_entry coqide "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+ fi
+
+ local ocamlc_where
+ ocamlc_where="$(ocamlc -where)"
+
+ # Dune installs into /usr/<libdir>/ocaml/<coq> but
+ # Coq wants /usr/<libdir>/<coq> ; symlink those directories
+ local sym
+ for sym in "${DUNE_PACKAGES[@]}" ; do
+ dosym "${ocamlc_where}/${sym}" "/usr/$(get_libdir)/${sym}"
+ done
+
+ einstalldocs
+}
diff --git a/sci-mathematics/coq/coq-8.19.2.ebuild b/sci-mathematics/coq/coq-8.19.2.ebuild
index 4be3a3484836..b18c93f1bb56 100644
--- a/sci-mathematics/coq/coq-8.19.2.ebuild
+++ b/sci-mathematics/coq/coq-8.19.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
-KEYWORDS="amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
IUSE="debug doc gui +ocamlopt test"
# TODO: Lots of failing tests. Maybe investigate later.
diff --git a/sci-mathematics/coq/coq-8.20.0.ebuild b/sci-mathematics/coq/coq-8.20.0.ebuild
index ed305875cdd0..67166c74be15 100644
--- a/sci-mathematics/coq/coq-8.20.0.ebuild
+++ b/sci-mathematics/coq/coq-8.20.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ else
SRC_URI="https://github.com/coq/coq/archive/V${PV}.tar.gz
-> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
+ KEYWORDS="amd64 ~arm64 ~x86"
fi
LICENSE="LGPL-2.1"
diff --git a/sci-mathematics/why3-for-spark/Manifest b/sci-mathematics/why3-for-spark/Manifest
index 29f43833e16e..68816295ed9a 100644
--- a/sci-mathematics/why3-for-spark/Manifest
+++ b/sci-mathematics/why3-for-spark/Manifest
@@ -6,5 +6,5 @@ AUX why3-for-spark-2023.12.13-flags.patch 863 BLAKE2B c6456f944667dc72eb87b2e76d
DIST why3-2021-20210519-19ADF-src.tar.gz 10386938 BLAKE2B 93b6323c562126244f5cccef34088a521fe3dc1cec07c966e94472503ec8492707b20a641936449307f0439e711a82260d36679cbc69f53df8e7886a1d3673c3 SHA512 65e3c1430001962f2c7cce786f3e30f14b5295cff89c4087d95c1545e81743723319ba0309dbe15c4c46552110b25ff57addc3ee085dade02ea59a2273b127db
DIST why3-for-spark-2023.12.13.tar.gz 7119379 BLAKE2B 4fd78efaabc2ca40853a905b1581ed976660f5b1b01ab9490c422022284132d8306289aad3eb2111d85d5cde5b50242b5d94d313e8d78a7443b7fcc4298fd11b SHA512 88220595eae9c5cf4125c0dc9d5176e637a1f1e355f61f51176bdb7643a000c837e501101e45c2b50ae3f41f81436e1133be241fd5fb0b6816823b2106113ae7
EBUILD why3-for-spark-2021-r1.ebuild 3103 BLAKE2B fd8e8cd70d1d38c69fad088c3ba66f101e335bea625ab3dffe996d1462f364a2e4e5489869c462396b4a0ec7a4e418df593f1869927188840ffadd4b56a02cb6 SHA512 dc2472a0a6375bb8cf08760d438fdb4cd3f4dcc41063f6b4950657cf7d277c7b6506269fbbd8c711b951fc8cfb8d65fde9df5fa4af556c7a68814001961370e9
-EBUILD why3-for-spark-2023.12.13.ebuild 3023 BLAKE2B 0184260f5a33640e520bb05199d38f98860dd03e2e09e179cd6a7052c104901b5d6004445566366c127ae595c0e5dbea8017e9f767b7fe638f5f7dc4972ac6ab SHA512 cf860788b9775ebaa7924f6b5ae977d74f02e56e05abd43dc82a3a74c4fd057597d351988d6c66bdc9e6d7f556d9a6ee5c793db59584b723886f86732ec55af1
+EBUILD why3-for-spark-2023.12.13-r1.ebuild 3107 BLAKE2B 1477f170923229bd641f61f22259263a028777807b9c99adcf055b14ca1f773e31107d3ce0f347c14feac6e807754b7828cb63489513ef29a67a5ef7dcc0782b SHA512 516831ad8f2974dbaf39bc3de92108c73c12dee9a8a1e2d307ede4cfff3a8dae77aeb332d0a8e63765b63674052b7d2dba90eea0454cf7598692e6ac770e71e1
MISC metadata.xml 1561 BLAKE2B 48c1ebe394b9a4152cd3b3a0560ff5e2d0e93e48422265d224b49b80b5b625b110f3561a09825e7e6efaf1dbb1dca8362612cfdccd43d954f4a848fb39624653 SHA512 02c1cecdd192e289d0146d0ba16148a2fcd9daddc39b6afbaa2a510594475a12cacd4b4c92d1c1b7bf40c291a90d66b887fdbf19fa82af45f197e2323e4b2b20
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2023.12.13.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2023.12.13-r1.ebuild
index fcbbcab6ccbc..098fc91adf34 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2023.12.13.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2023.12.13-r1.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}"/why3-${ID}
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt sexp zarith zip"
RESTRICT="strip"
@@ -25,7 +25,7 @@ RDEPEND="
dev-ml/menhir:=[ocamlopt?]
dev-ml/num:=[ocamlopt?]
dev-ml/yojson:=
- coq? ( sci-mathematics/coq )
+ coq? ( <=sci-mathematics/coq-8.18 )
emacs? ( app-editors/emacs:* )
gtk? ( dev-ml/lablgtk:=[sourceview] )
html? ( dev-tex/hevea:= )
@@ -71,6 +71,9 @@ REQUIRED_USE="html? ( doc ) ocamlopt"
src_prepare() {
find examples -name \*gz | xargs gunzip
+ sed -i \
+ -e 's:configure.in:configure.ac:g' \
+ Makefile.in || die
eautoreconf
default
}