summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19316 -> 19317 bytes
-rw-r--r--sci-mathematics/pari/Manifest2
-rw-r--r--sci-mathematics/pari/pari-2.15.5.ebuild137
3 files changed, 139 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index ae7714804dc5..2f35035e4f3d 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index 65760df152d1..b5400bc4cfeb 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -1,5 +1,7 @@
AUX pari-2.11.2-no-automagic.patch 2349 BLAKE2B 6c2cdda84342109bad0cbfb3d5188eedbbfc08e5b40bce3f045309cef936f88356324b6d721c5cdb458a2343fb4ee6473238571dd779b74506e7e2b7d835e0c7 SHA512 549acaeaa393b0b42818e3648c21fdba3162abfefef147a1429d0e39f58ece0a46e94a6ee953435549c23d62b115b2dab0ee261eda2eb7fd0a2b430223f5f59c
AUX pari-2.9.4-fltk-detection.patch 572 BLAKE2B 1c2e1fa6e52521c7865c3fd011824c83fa92623903dd1e056bda29c6735eb01013e7937f66d6ffff42d0de83f7ed104c7f933d232ee37be7c4351788e76f8daa SHA512 2ec0d8035a87b693ee6a4dfa913f0b24eed20bb4db7f8cd1a47db444310d33d19e6651d475c635be747e79a02df2705e42f6f7032b60dc763583cf9fa8633b29
DIST pari-2.15.4.tar.gz 5183685 BLAKE2B 2e20b6dc073ce69bc098dd849e6ab43cb38b05d30ff5f72a31272cd24ef01aa515d4e2a4948264ca89169a6980cd9d76f86c7fbb9aad5be604680569950d9c25 SHA512 2b9f0c1fe7198406df8e6ceb3fcdc8bfb75f5c7ebfb963f023a1eebfff0bcc26e3b690941e188d6b9f8dfb6cddf4ce4c00f2cc320ebe47d42ae7596c774ed6cc
+DIST pari-2.15.5.tar.gz 5186798 BLAKE2B b253c6d8ad38462e81852d7bb364d06a7cbaae7b085672653da8d9f91f0173cfdef8f537ebc7313b6484f610d43e10fb0547f5d920789b95c8d0027dd52e8312 SHA512 59b2ebed43176f1ee750146053644bffbf673b4b4810134bc39132665941152772afb7a9332b842fc64e5ab8d5747a872c1b8ff327d3bd5eedaa1591691fff13
EBUILD pari-2.15.4-r1.ebuild 4724 BLAKE2B cdd4bd4805b870700e7f190bf220f21c5f55ab7627c141122aa97dc92f12ea605abfab9d417e873fafc6a6d38cd8e57f734c9626de48d10e1d78a4d4a7dcebbb SHA512 d8a740394bca755e34445fcf4ead7841e5d3a47edd67dcb86f2cb134c705e847fdd7c89105c66029a3ccf254c669c1e150995267a976bc2d9f920197fb5b0f4b
+EBUILD pari-2.15.5.ebuild 4446 BLAKE2B 6884828e06727b54f811c8c226324018ecbfbe4846d8d0c1a2229ecac946d1dcd2fcd2e28f808578c90e4dc9b1336957c750c5a22c66c6a51ca2ab58b34a75b0 SHA512 f17c6c2ddd4b01b0575615d2a636d39de860e74f54b18b266a604819a71186f5b8ec2445c5054824bf6f41c36a656bd60f494aa208a5eaa2edef890a1acda36a
MISC metadata.xml 1770 BLAKE2B d730330ac80159a9e46a7c892049d00e28bfe9e4d4c61616c033ccaf526cfef6f95a03bac803bf70c59760e1833e35fce5bc535038aadc8db68dca878c7bde78 SHA512 387a8eb845634e8568a3e98f44f9b92bd7819870ebb6cb57b28e96c0df022b4436074fa526771f5e6793ce59c010c0c0437abb63f03ec9890bca3c301afcf9ee
diff --git a/sci-mathematics/pari/pari-2.15.5.ebuild b/sci-mathematics/pari/pari-2.15.5.ebuild
new file mode 100644
index 000000000000..6c8fe6f9b29e
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.15.5.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Computer-aided number theory C library and tools"
+HOMEPAGE="https://pari.math.u-bordeaux.fr/"
+SRC_URI="https://pari.math.u-bordeaux.fr/pub/${PN}/unix/${P}.tar.gz"
+
+# Their LICENSE file says "or (at your option) any later version"
+LICENSE="GPL-2+"
+
+# The subslot is the value of $soname_num obtained from
+# upstream's config/version script.
+SLOT="0/8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="data doc examples fltk gmp test threads X"
+REQUIRED_USE="fltk? ( !X )" # mutually exclusive plot implementations
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+"
+DEPEND="
+ sys-libs/readline:0=
+ data? ( sci-mathematics/pari-data )
+ doc? ( X? ( x11-misc/xdg-utils ) )
+ fltk? ( x11-libs/fltk:1= )
+ gmp? ( dev-libs/gmp:0= )
+ X? ( x11-libs/libX11:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # move doc dir to a gentoo doc dir and replace acroread by xdg-open
+ sed -i \
+ -e "s:\$d = \$0:\$d = '${EPREFIX}/usr/share/doc/${PF}':" \
+ -e 's:"acroread":"xdg-open":' \
+ doc/gphelp.in || die "Failed to fix doc dir"
+
+ # These tests fail when LaTeX is not installed (which we don't
+ # require without USE=doc), most likely due to output formatting
+ # issues but I haven't deleted my LaTeX installation to check.
+ # There's no real upstream support for enabling/disabling the LaTeX
+ # docs, so this is probably the correctest way to skip these tests.
+ if ! use doc; then
+ rm src/test/{in,32}/help || die
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX PKG_CONFIG
+
+ # Workaraound to "asm operand has impossible constraints" as
+ # suggested in bug #499996.
+ use x86 && append-cflags $(test-flags-CC -fno-stack-check)
+
+ # sysdatadir installs a pari.cfg stuff which is informative only.
+ # It is supposed to be for "architecture-dependent" data. It needs
+ # to be easily discoverable for downstream packages such as gp2c.
+ # We set LD="" and DLLD="$CC" so that the "shared library linker"
+ # always gets set to the value of the compiler used. Pari's build
+ # system does not cope very well with a naked linker, it is
+ # expecting a compiler driver. See bugs 722090 and 871117.
+ # DLLDFLAGS, on the other hand, is used exactly like LDFLAGS would
+ # be in a less-weird build system.
+ #
+ # There's a lot of automagic involved in the graphics detection. We
+ # first pass --graphic=none, which disables some of it. We then pass
+ # --graphic=fltk (or --graphic=X11) only if USE=fltk (or USE=X) is
+ # set. This is a stronger hint to the build system than --with-fltk
+ # would be, and importantly does not rely on the corresponding but
+ # nonexistent(!) option option for X11.
+ LD="" DLLD="$(tc-getCC)" DLLDFLAGS="${LDFLAGS}" ./Configure \
+ --prefix="${EPREFIX}"/usr \
+ --datadir="${EPREFIX}/usr/share/${PN}" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --sysdatadir="${EPREFIX}"/usr/share/pari \
+ --mandir="${EPREFIX}"/usr/share/man/man1 \
+ --with-readline="${EPREFIX}"/usr \
+ --with-readline-lib="${EPREFIX}/usr/$(get_libdir)" \
+ --with-ncurses-lib="${EPREFIX}/usr/$(get_libdir)" \
+ --graphic=none \
+ $(usex X --graphic=X11 "" "" "") \
+ $(usex fltk --graphic=fltk "" "" "") \
+ $(use_with gmp) \
+ $(usex threads "--mt=pthread" "" "" "") \
+ || die "./Configure failed"
+}
+
+src_compile() {
+ emake gp
+
+ if use doc; then
+ # To prevent sandbox violations by metafont
+ VARTEXFONTS="${T}/fonts" emake docpdf
+ fi
+}
+
+src_test() {
+ # Welcome to the jungle, where the tests fail if you make your
+ # terminal bigger.
+ emake COLUMNS=80 test-all
+}
+
+src_install() {
+ DOCS=( AUTHORS CHANGES* COMPAT NEW README* )
+
+ # Install examples to a junk location by default because "make
+ # install-nodata" includes the examples with it. Only if the user
+ # has USE=examples set do we provide the correct directory.
+ local exdir="${T}"
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ exdir="${ED}/usr/share/doc/${PF}/examples"
+ fi
+
+ # Use "true" in place of "strip" to sabotage the unconditional
+ # binary stripping.
+ emake DESTDIR="${D}" \
+ EXDIR="${exdir}" \
+ STRIP="true" \
+ install-nodata install-data
+ einstalldocs
+
+ if use doc; then
+ docompress -x "/usr/share/doc/${PF}"
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install-docpdf install-doctex
+ fi
+}