summaryrefslogtreecommitdiff
path: root/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/vampire/vampire-4.6.1-r1.ebuild')
-rw-r--r--sci-mathematics/vampire/vampire-4.6.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild b/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild
index 2f7ceabc3b2c..98b642f86d90 100644
--- a/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild
+++ b/sci-mathematics/vampire/vampire-4.6.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit flag-o-matic cmake
DESCRIPTION="The Vampire Prover, theorem prover for first-order logic"
HOMEPAGE="https://vprover.github.io"
@@ -33,6 +33,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_configure() {
+ # -Werror=strict-aliasing warnings, bug #863269
+ filter-lto
+ append-flags -fno-strict-aliasing
+
local CMAKE_BUILD_TYPE
if use debug; then
CMAKE_BUILD_TYPE=Debug