summaryrefslogtreecommitdiff
path: root/sci-mathematics/stp/stp-2.3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/stp/stp-2.3.3-r1.ebuild')
-rw-r--r--sci-mathematics/stp/stp-2.3.3-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-mathematics/stp/stp-2.3.3-r1.ebuild b/sci-mathematics/stp/stp-2.3.3-r1.ebuild
index 367251ea5f8f..67fbceb1ce9d 100644
--- a/sci-mathematics/stp/stp-2.3.3-r1.ebuild
+++ b/sci-mathematics/stp/stp-2.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ GT_H=2ad076167a676e3ed62f90b754b30fac5caa1f88
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit python-single-r1 cmake
+inherit flag-o-matic python-single-r1 cmake
DESCRIPTION="Simple Theorem Prover, an efficient SMT solver for bitvectors"
HOMEPAGE="https://stp.github.io/"
@@ -71,12 +71,16 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr warnings, bug #863263
+ filter-lto
+
local CMAKE_BUILD_TYPE
if use debug ; then
CMAKE_BUILD_TYPE=Debug
else
CMAKE_BUILD_TYPE=Release
fi
+
local mycmakeargs=(
-DNOCRYPTOMINISAT=$(usex cryptominisat 'OFF' 'ON') # double negation
-DENABLE_PYTHON_INTERFACE=$(usex python)