summaryrefslogtreecommitdiff
path: root/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild')
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
new file mode 100644
index 000000000000..2ea39b2a42f1
--- /dev/null
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Multiple independent streams of pseudo-random numbers"
+HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT=0
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r doc/rngstreams.html/* && dodoc doc/${PN}.pdf
+ if use examples; then
+ rm examples/Makefile*
+ dodoc -r examples
+ fi
+}