summaryrefslogtreecommitdiff
path: root/sci-mathematics/rkward/rkward-0.6.5_p20170420.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rkward/rkward-0.6.5_p20170420.ebuild')
-rw-r--r--sci-mathematics/rkward/rkward-0.6.5_p20170420.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/rkward-0.6.5_p20170420.ebuild b/sci-mathematics/rkward/rkward-0.6.5_p20170420.ebuild
new file mode 100644
index 000000000000..f3bea9438c61
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.6.5_p20170420.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="https://rkward.kde.org/"
+SRC_URI="https://dev.gentoo.org/~kensington/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-lang/R
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ !sci-mathematics/rkward:4
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"