summaryrefslogtreecommitdiff
path: root/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild')
-rw-r--r--sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild b/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
index 4e0ada140fe7..5f6f9e6f4f39 100644
--- a/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
+++ b/sci-mathematics/psmt2-frontend/psmt2-frontend-0.2.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/OCamlPro-Coquera/${PN}/archive/${PV}.tar.gz -> ${P}.
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE=""
DEPEND=">=dev-ml/menhir-20181006"
@@ -21,5 +21,14 @@ PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_prepare() {
default
+ mv configure.{in,ac}
+ sed -i \
+ -e "s:configure.in:configure.ac:g" \
+ Makefile.in || die
eautoreconf
}
+
+src_compile() {
+ emake depend
+ default
+}