summaryrefslogtreecommitdiff
path: root/sci-mathematics/normaliz/normaliz-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/normaliz/normaliz-3.1.1.ebuild')
-rw-r--r--sci-mathematics/normaliz/normaliz-3.1.1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/sci-mathematics/normaliz/normaliz-3.1.1.ebuild b/sci-mathematics/normaliz/normaliz-3.1.1.ebuild
deleted file mode 100644
index 69b0f3c68a98..000000000000
--- a/sci-mathematics/normaliz/normaliz-3.1.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs versionator
-
-MYPV=$(get_version_component_range 1-2)
-MYP="Normaliz${MYPV}"
-
-DESCRIPTION="Tool for computations in affine monoids and more"
-HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
-SRC_URI="https://www.normaliz.uni-osnabrueck.de/wp-content/uploads/2016/04/Normaliz${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="doc extras openmp"
-
-RDEPEND="dev-libs/gmp[cxx]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-libs/boost"
-# Only a boost header is needed -> not RDEPEND
-
-S=${WORKDIR}/${MYP}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0.0-respect-flags.patch"
-
- # Respect users AR tool (Bug 474532)
- sed -e "s:ar -cr:$(tc-getAR) -cr:" -i source/libnormaliz/Makefile || die
-
- if use openmp && tc-has-openmp; then
- export OPENMP=yes
- else
- export OPENMP=no
- fi
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
-}
-
-src_install() {
- dobin source/normaliz
- if use doc ; then
- dodoc doc/"Normaliz.pdf"
- dodoc doc/"NmzIntegrate.pdf"
- fi
- if use extras; then
- elog "You have selected to install extras which consist of Macaulay2"
- elog "and Singular packages. These have been installed into "
- elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
- elog "to the homepages of the respective projects for additional information."
- elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
- elog "copies of these interface packages. Usually you don't need normaliz's versions."
- insinto "/usr/share/${PN}"
- doins Singular/normaliz.lib
- doins Macaulay2/Normaliz.m2
- fi
-}