summaryrefslogtreecommitdiff
path: root/sci-mathematics/nestedsums
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/nestedsums')
-rw-r--r--sci-mathematics/nestedsums/Manifest2
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild (renamed from sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild)13
2 files changed, 10 insertions, 5 deletions
diff --git a/sci-mathematics/nestedsums/Manifest b/sci-mathematics/nestedsums/Manifest
index 5596c5111021..b2c877695477 100644
--- a/sci-mathematics/nestedsums/Manifest
+++ b/sci-mathematics/nestedsums/Manifest
@@ -1,3 +1,3 @@
DIST nestedsums-1.5.2.tar.gz 511806 BLAKE2B 9c40f4b3405134ea058aad356e131b29f7f0a058b68ed3081bbcc51d451e850bccd8ec26448a8ac391524913da7eccbce4fae1b9e4119c8692b8fca59a17d885 SHA512 2b7dd54e02695a741bbe8cc0b45a3804dc7c1cb6d0b46ad7c152489e952718b438b84d60b844ff0ed92b32c78186dac2d4ee8e705ad82f965bbec923c1970d33
-EBUILD nestedsums-1.5.2.ebuild 827 BLAKE2B 2a8fa6a9d64e94d08ca0fa3756b211aac0c3af1eddb14af56e7f1fec6f9c518358ba03922f53842ca9e3ad0e5ede5f74d90b96587bf88776450799590c3c8e54 SHA512 55a253f7fbb5b2bd579eefbc88cf5f86cbddb5fda9fc396a119f9ddd360dcb0cc1ca4bd5ab653494d66ee367d1e0287f00d52de3a0269712b68bc4538c1db099
+EBUILD nestedsums-1.5.2-r1.ebuild 996 BLAKE2B 859641ac39630571df447b112d3e2a85afd9e2a75b42f68c25cf946aabfc69df6e9a24bb419b3309a2ebd265e009c04aa6c95531bdfcb07b7b47ebf21a01d85e SHA512 1b56798b8eb0f3dde04b62e9d7a6250c2687a95dc17e45ffa8c33325d604a68c7ab94f05f80c2bb264181ff347892e8759bb4c5ce40e663c067e9d54d16cb51e
MISC metadata.xml 501 BLAKE2B dd148f912baaaece32f3d6ebc779762b01496f1384f88a54e83c98e9f6a913d52e1dd6da962ae64a3a223846d83d4597cba0ced20c6ea6c7fc35775f7376d1f2 SHA512 5869e4268ec16289d392ec2911f1297e19e06cff94b8dac6f4cf57adaeb9fba1dba8853433bed1154a3bd2048cf5b762d6560a70a30fb5de230b5ce6ce1b775c
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild
index 3f4b9497fb6b..99a09d617d4b 100644
--- a/sci-mathematics/nestedsums/nestedsums-1.5.2.ebuild
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.2-r1.ebuild
@@ -3,19 +3,24 @@
EAPI=7
-inherit flag-o-matic
+inherit multilib flag-o-matic
DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
HOMEPAGE="https://particlephysics.uni-mainz.de/weinzierl/nestedsums/"
-IUSE="doc"
+IUSE="doc static-libs"
SRC_URI="http://particlephysics.uni-mainz.de/weinzierl/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=sci-mathematics/ginac-1.7"
+RDEPEND=">=sci-mathematics/ginac-1.7[static-libs=]"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+src_configure() {
+ append-cxxflags -std=c++14
+ econf $(use_enable static-libs static)
+}
+
src_compile() {
default
@@ -30,7 +35,7 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install
- rm -f "${D}"/usr/lib/*.la
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "cannot rm lib${PN}.la"
dodoc AUTHORS ChangeLog
if use doc; then