summaryrefslogtreecommitdiff
path: root/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild')
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
deleted file mode 100644
index 2856746b2ef3..000000000000
--- a/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Elliptic Curve Method for Integer Factorization"
-HOMEPAGE="http://ecm.gforge.inria.fr/"
-#SRC_URI="https://gforge.inria.fr/frs/download.php/30965/${P}.tar.gz"
-ESVN_REPO_URI="svn://scm.gforge.inria.fr/svnroot/ecm/trunk"
-
-inherit autotools eutils flag-o-matic subversion
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="blas -openmp test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/gmp:0=
- blas? ( sci-libs/gsl )
- openmp? ( sys-devel/gcc:*[openmp] )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/ecm-${PV}
-
-MAKEOPTS+=" -j1"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- # --enable-shellcmd is broken
- econf $(use_enable openmp) $myconf
-}
-
-src_compile() {
- append-ldflags "-Wl,-z,noexecstack"
- # the custom-tune bits are obsoleted with sane defaults
- default
-}
-
-src_install() {
- default
- mkdir -p "${D}/usr/include/${PN}/"
- cp "${S}"/*.h "${D}/usr/include/${PN}" || die "Failed to copy headers" # needed by other apps like YAFU
-}