summaryrefslogtreecommitdiff
path: root/sci-mathematics/ginac/ginac-1.7.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/ginac/ginac-1.7.11.ebuild')
-rw-r--r--sci-mathematics/ginac/ginac-1.7.11.ebuild68
1 files changed, 37 insertions, 31 deletions
diff --git a/sci-mathematics/ginac/ginac-1.7.11.ebuild b/sci-mathematics/ginac/ginac-1.7.11.ebuild
index bd90fbd5c1b4..6bd2388f1c08 100644
--- a/sci-mathematics/ginac/ginac-1.7.11.ebuild
+++ b/sci-mathematics/ginac/ginac-1.7.11.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib flag-o-matic
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-any-r1
DESCRIPTION="C++ library and tools for symbolic calculations"
SRC_URI="http://www.ginac.de/${P}.tar.bz2"
@@ -11,59 +13,63 @@ HOMEPAGE="https://www.ginac.de/"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
RDEPEND=">=sci-libs/cln-1.2.2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
virtual/pkgconfig
- doc? ( app-doc/doxygen
- media-gfx/transfig
- virtual/texi2dvi
- dev-texlive/texlive-fontsrecommended
- )"
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-fontsrecommended
+ media-gfx/transfig
+ virtual/texi2dvi
+ )"
PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
src_configure() {
- append-cxxflags -std=c++14
- econf --disable-rpath $(use_enable static-libs static)
+ econf \
+ --disable-rpath \
+ --disable-static
}
src_compile() {
emake
+
if use doc; then
- export VARTEXFONTS="${T}"/fonts
- pushd doc/reference >> /dev/null || die "pushd doc/reference failed"
- emake html pdf
- popd >> /dev/null
- pushd doc/tutorial >> /dev/null || die "pushd doc/tutorial failed"
- emake ginac.pdf ginac.html
- popd >> /dev/null
+ local -x VARTEXFONTS="${T}"/fonts
+ emake -C doc/reference html pdf
+ emake -C doc/tutorial ginac.pdf ginac.html
fi
}
-src_test() {
- pushd ../${P}_build > /dev/null
- emake check
- popd > /dev/null
-}
-
src_install() {
default
- if ! use static-libs; then
- rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "cannot rm lib${PN}.la"
- fi
+
if use doc; then
- pushd doc > /dev/null || die "pushd doc failed"
+ pushd doc >/dev/null || die
newdoc tutorial/ginac.pdf tutorial.pdf
newdoc reference/reference.pdf reference.pdf
+
docinto html/reference
dodoc -r reference/html_files/.
+
docinto html
newdoc tutorial/ginac.html tutorial.html
+ popd >/dev/null || die
+ fi
+
+ if use examples; then
+ pushd doc >/dev/null || die
docinto examples
- dodoc "${S}"/doc/examples/*.cpp examples/ginac-examples.*
- popd > /dev/null
+ dodoc examples/*.cpp examples/ginac-examples.*
+ docompress -x /usr/share/doc/${PF}/examples
+ popd >/dev/null || die
fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}