summaryrefslogtreecommitdiff
path: root/sci-mathematics/gappalib-coq
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gappalib-coq')
-rw-r--r--sci-mathematics/gappalib-coq/Manifest3
-rw-r--r--sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild40
-rw-r--r--sci-mathematics/gappalib-coq/metadata.xml12
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/gappalib-coq/Manifest b/sci-mathematics/gappalib-coq/Manifest
new file mode 100644
index 000000000000..e244d009e4fe
--- /dev/null
+++ b/sci-mathematics/gappalib-coq/Manifest
@@ -0,0 +1,3 @@
+DIST gappalib-coq-1.5.2.tar.gz 115236 BLAKE2B a2515d488e229cfe8dd44ac3508af9b8e0ad96dda7cb4ffdbea7f4d75e97a3263c29a043b6484351df995129c77af9af11d3c226dd4f63630816f50a9a50639a SHA512 4b3d8dcb5d97a5fb9fad9d9997eb1f19a62262ea930e157e10dd06ef7f99cc45a25a024f03ce984ebd0d142edd62dbbdbd832a4da41ea5eb8ea3287c7109dda2
+EBUILD gappalib-coq-1.5.2.ebuild 870 BLAKE2B e61f54ff79540a430742a41897e2d9330f05c1cb415ab841b1097093648ec430172c1e9d3b8fc184693774e44979e2abf103d5d1d4f808f97a276dcb7f3d5a52 SHA512 7970659f8c1afc78413e1a851f837d4e35b58ced654c034dfd42c177514a106236ded2e93e9f848397ba287988098147f65a1156f627cb68303f33f9654fa7c6
+MISC metadata.xml 371 BLAKE2B 26fa03c1744ed1095e80664102babf630ebf838b140f3b1167e73bb0aa7b63098ad5c41ff630177f6f1d012d3be0c29271c2286b801e9e8997eedbf94c112750 SHA512 ab218d803ec01b9fd7a76af71eca0cc51588da4224a07c6d3c947f3c56136f9106b4a12f4a083d518398526ad34e6b4c90fcb52994a84cc7c6e12f54cb0820f8
diff --git a/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild b/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild
new file mode 100644
index 000000000000..6bf57a25ef10
--- /dev/null
+++ b/sci-mathematics/gappalib-coq/gappalib-coq-1.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing
+
+DESCRIPTION="Allows the certificates Gappa generates to be imported by the Coq"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/
+ https://gitlab.inria.fr/gappa/coq/"
+SRC_URI="https://gappa.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=sci-mathematics/coq-8.12
+ sci-mathematics/flocq
+ sci-mathematics/gappa
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+# Do not complain about CFLAGS etc since ML projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+}
+
+src_test() {
+ ./remake --jobs=$(makeopts_jobs) check || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ dodoc AUTHORS INSTALL.md NEWS.md README.md
+}
diff --git a/sci-mathematics/gappalib-coq/metadata.xml b/sci-mathematics/gappalib-coq/metadata.xml
new file mode 100644
index 000000000000..c071e7661ba7
--- /dev/null
+++ b/sci-mathematics/gappalib-coq/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.inria.fr/gappa/coq/-/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>