summaryrefslogtreecommitdiff
path: root/sci-mathematics/fricas
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/fricas')
-rw-r--r--sci-mathematics/fricas/Manifest4
-rw-r--r--sci-mathematics/fricas/fricas-1.3.9.ebuild110
-rw-r--r--sci-mathematics/fricas/metadata.xml1
3 files changed, 114 insertions, 1 deletions
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index 6119ee3781bb..ed6f4eeb28b0 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1,4 +1,6 @@
AUX fricas-sbcl-2.3.2.patch 656 BLAKE2B 2b4e2ade98651f221461991464d70eb0e0ec3d534c0f9e0b98f790506acf94a2cc7eae9d8b20ab704c1dba156301b2703b9a5d1b78296f4f1eafa9d2cda091ea SHA512 e5134750092b4efd517311b1734d39cd4c2617e390d5228df7e393a2b95b1ccbd68119d5fb3e9322ddc6a346d5741ac41db8912306ea8b97960482fdb04c2c23
DIST fricas-1.3.8-full.tar.bz2 10878913 BLAKE2B 214eecd430a2b758a10d985f512f3c79f6b12de35bc29e8f0a3fd296fe871b2e9a6b362060cbeec317dc355bd3c661fcab44087feeaa092fe6afcdebd0fb94a8 SHA512 330554f9dc36b47451195e3dee88fe26a80ab2bf9b6750d651cd53c5ba16b9c9736176936c7c69e699685be25aa62b6a099ed7340913e946a4f5e53579835dbb
+DIST fricas-1.3.9.full.tar.bz2 10949173 BLAKE2B c535d2a384fa55db53b6901d3ba5d1cc8eca35ccf67a2664f934da427a808b5adc7a5522b935f5dcff89795c0ca5816818d9cf37399b6f9bdc63cfe4d622a7c3 SHA512 9cfcb8bad52550a46216509154d5c06dac23625bc14d504a1febbea7ff771fd3172f91c2824df51375b8d85adc19959a5cbbfa2b77a0095ca37e8a4d4b8cc405
EBUILD fricas-1.3.8-r1.ebuild 2465 BLAKE2B fcaa6624015409bda2208852822991bd7bbf930604695a090f95c0c3c9d1a85d3b57722a7a2fb7474c0b3a3d5ce877ea1f653a50f7852698ebb568ac484a3170 SHA512 bf02a18f3fe11e72b60f2aff1b14144491efadb839f97b48456364a93acba616ea5e88b5d2542031d7e2db2f5c0ac6c6bf03812ce65e66272f1fbaf3ca4ab2f2
-MISC metadata.xml 1062 BLAKE2B 06f8df085a48986321da6e195d8c13463929b5f49ee55ee683846e5a2a3281dd722a06339e4550cbf1d928b05fdf41b6a623777aa858146d81fac178700f7c15 SHA512 9848d78cf0ac1db0258213a48f47caf3380e1b2b64be8c3e33ae8d3b53543ba81ebd7eb0e470559bc97a14571cb4e82721d83ff50b9f01129933385eacf5e0ad
+EBUILD fricas-1.3.9.ebuild 2421 BLAKE2B dd12613e17a21fc97b01683bfd5b8cf73a6a46be784a3dd9d5c67d0c5054005c2459b3a10be800d0801835f462b209f5bf7aab87ab2b2b50fb78b32f34fc3091 SHA512 dbd6608ace1a241a3fd4cc104c847a8e652042cd321938b1dec02d2211d8cbd40535a78c3cd365371100732facb2c17cec46ba89f9b55e799a9b04ef7a984487
+MISC metadata.xml 1117 BLAKE2B 14376a1b8894543618dd6204b4cf28f8d24b175a9258484e14866f6ad6c60d2369830c49221d06c37c63c35b886b7ce2d04334510f1640c6e27809762dc10a19 SHA512 83c6155c3a2341d655621f308109840dfae3a758d4e157b517363744f5d08bb03de984ef675f923c9c74d4793ac14bd5427cce89c5a0f340431fc6040b582cdb
diff --git a/sci-mathematics/fricas/fricas-1.3.9.ebuild b/sci-mathematics/fricas/fricas-1.3.9.ebuild
new file mode 100644
index 000000000000..e3004457c1e1
--- /dev/null
+++ b/sci-mathematics/fricas/fricas-1.3.9.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit elisp-common
+
+DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
+HOMEPAGE="http://fricas.sourceforge.net/
+ https://github.com/fricas/fricas
+ https://fricas.github.io/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.full.tar.bz2"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps, number 0 is the default
+LISPS=( sbcl cmucl gcl ecls clisp clozurecl )
+# Version restrictions, . means no restrictions
+REST=( . . . . . . )
+# command name: . means just ${LISP}
+COMS=( . lisp . ecl . ccl )
+
+IUSE="${LISPS[*]} X emacs gmp"
+RDEPEND="X? ( x11-libs/libXpm x11-libs/libICE )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ gmp? ( dev-libs/gmp:= )"
+
+# Generating lisp deps
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ LISP=${LISPS[$n]}
+ if [ "${REST[$n]}" = "." ]; then
+ DEP="dev-lisp/${LISP}"
+ else
+ DEP="${REST[$n]}"
+ fi
+ RDEPEND="${RDEPEND} ${LISP}? ( ${DEP}:= ) !${LISP}? ("
+done
+if [ "${REST[0]}" = "." ]; then
+ DEP="dev-lisp/${LISPS[0]}"
+else
+ DEP="${REST[0]}"
+fi
+RDEPEND="${RDEPEND} ${DEP}:="
+n=${#LISPS[*]}
+for ((n--; n > 0; n--)); do
+ RDEPEND="${RDEPEND} )"
+done
+
+DEPEND="${RDEPEND}"
+
+# necessary for clisp and gcl
+RESTRICT="strip"
+
+src_configure() {
+ local LISP n GMP
+ LISP=sbcl
+ n=${#LISPS[*]}
+ for ((n--; n > 0; n--)); do
+ if use ${LISPS[$n]}; then
+ LISP=${COMS[$n]}
+ if [ "${LISP}" = "." ]; then
+ LISP=${LISPS[$n]}
+ fi
+ fi
+ done
+ einfo "Using lisp: ${LISP}"
+
+ # bug #650788
+ if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
+ then GMP=$(use_with gmp)
+ else GMP=''
+ fi
+
+ # aldor is not yet in portage
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
+}
+
+src_compile() {
+ # bug #300132
+ emake -j1
+}
+
+src_test() {
+ emake -j1 all-input
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc README.rst FAQ
+
+ if use emacs; then
+ sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
+ -i "${D}"/usr/bin/efricas \
+ || die "sed efricas failed"
+ elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
+ elisp-make-site-file 64${PN}-gentoo.el
+ else
+ rm "${D}"/usr/bin/efricas || die "rm efricas failed"
+ fi
+ rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/fricas/metadata.xml b/sci-mathematics/fricas/metadata.xml
index c17dd82db612..5f547acf8a41 100644
--- a/sci-mathematics/fricas/metadata.xml
+++ b/sci-mathematics/fricas/metadata.xml
@@ -25,5 +25,6 @@
</use>
<upstream>
<remote-id type="sourceforge">fricas</remote-id>
+ <remote-id type="github">fricas/fricas</remote-id>
</upstream>
</pkgmetadata>