summaryrefslogtreecommitdiff
path: root/sci-mathematics/ent/ent-101202.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/ent/ent-101202.ebuild')
-rw-r--r--sci-mathematics/ent/ent-101202.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sci-mathematics/ent/ent-101202.ebuild b/sci-mathematics/ent/ent-101202.ebuild
index 2c0a24c73daa..694df9dc8441 100644
--- a/sci-mathematics/ent/ent-101202.ebuild
+++ b/sci-mathematics/ent/ent-101202.ebuild
@@ -1,30 +1,29 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Pseudorandom number sequence test"
HOMEPAGE="http://www.fourmilab.ch/random/"
SRC_URI="mirror://gentoo/random-${PV}.zip"
+S="${WORKDIR}"
-SLOT="0"
LICENSE="public-domain"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
-S="${WORKDIR}"
+PATCHES=( "${FILESDIR}"/${PV}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ default
tc-export CC
}
src_install() {
dobin ${PN}
- dohtml ${PN}.html ${PN}itle.gif
+ dodoc ${PN}.html ${PN}itle.gif
}