summaryrefslogtreecommitdiff
path: root/sci-mathematics/easycrypt
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/easycrypt')
-rw-r--r--sci-mathematics/easycrypt/Manifest3
-rw-r--r--sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild38
-rw-r--r--sci-mathematics/easycrypt/metadata.xml18
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
new file mode 100644
index 000000000000..f3d073b6686b
--- /dev/null
+++ b/sci-mathematics/easycrypt/Manifest
@@ -0,0 +1,3 @@
+DIST easycrypt-1.0_pre20211210.tar.gz 1185137 BLAKE2B 3557a8b0423109a3b3e6e02f6d1ad88f07847d105015546c90b5a46cf514f1311390d3a6f6476c042420b91a62ad095919f7ab616adee2778165d9d081070730 SHA512 0043eac02e916dc46ed1cb4f278f148f915d09f336e904b1a711c18d62cda177e434fc13682ec095a085e458ba90ca8dd02968206af60f0b80a378f16b205553
+EBUILD easycrypt-1.0_pre20211210-r1.ebuild 854 BLAKE2B 69628e4415d62c8371ebcc43bf3a50e26417ab5bca67ad5a08b12352deee65cdc03217297a1f6e48191c5e25d679e0094c9b6b8eedb3a93128a65b85de8b327b SHA512 aaab397b4d3288b047f32a337beecf43262fbfe4fc702a501f359bc20eeb11a002b386c8772b429fc4fda3a033f51cc44fc8d0d0d5e4c0f88fcef12d5bf8bab8
+MISC metadata.xml 662 BLAKE2B de713a2c7c496742f1b793a0b8f1cd959d5c138af886455b9ee8479281098ead17f9e4f82cdf9d7e411b3bfe9db090d8a791da19856632e7d33b740aee1e9d3b SHA512 7c43407b9779c6c80550e1049897315b8b8ed18655e0987a477bf820040363739fa80e4c8c76c6b7278290d21d088a739eb1a4f357c03b86ff8f4bb69a8cb833
diff --git a/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild b/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild
new file mode 100644
index 000000000000..17f451552103
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="49aec58ea63a64adcf5fbabcc14c6739f337b206"
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="CeCILL-B CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.4:=
+ dev-ml/batteries:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
diff --git a/sci-mathematics/easycrypt/metadata.xml b/sci-mathematics/easycrypt/metadata.xml
new file mode 100644
index 000000000000..08fb88e8b7d7
--- /dev/null
+++ b/sci-mathematics/easycrypt/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ EasyCrypt is a toolset for reasoning about relational properties of
+ probabilistic computations with adversarial code. Its main application is
+ the construction and verification of game-based cryptographic proofs.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/EasyCrypt/easycrypt/issues/</bugs-to>
+ <remote-id type="github">EasyCrypt/easycrypt</remote-id>
+ </upstream>
+</pkgmetadata>