summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cvc4')
-rw-r--r--sci-mathematics/cvc4/Manifest2
-rw-r--r--sci-mathematics/cvc4/cvc4-1.8-r5.ebuild11
2 files changed, 12 insertions, 1 deletions
diff --git a/sci-mathematics/cvc4/Manifest b/sci-mathematics/cvc4/Manifest
index e2064a794821..7f8d1b2aa73d 100644
--- a/sci-mathematics/cvc4/Manifest
+++ b/sci-mathematics/cvc4/Manifest
@@ -3,5 +3,5 @@ AUX cvc4-1.8-gentoo.patch 1983 BLAKE2B bd9e7f8b442e151fdc27b45866ed4374ffcbeb5d3
AUX cvc4-1.8-musl.patch 3734 BLAKE2B 892dbba92594f7921932010327bc2110625a10d5cf6857e524c04e7266e7b335ff14d56b43c2b3d220c123a2af3a19ae7495b212896478d07a1da9faebb4d1fe SHA512 b82afaba8688da986b8578177c8e98b9586b63a5263cc9f9c001ec84390b3f7ba5f7028cf4b5a8cb026f980d285eabd68df7c0d93be063f720eae5eb168831a6
AUX cvc4-1.8-toml.patch 1329 BLAKE2B 39def94cd357381b277c5d5e8b39edc5d9e48ea8ecccf190cea13995b4da54a896d9c0f8cf714b8c74425da1c8269fd1cddbef2619a4f59cbc4090bc31ec14a4 SHA512 ca999ee52e8e91259772cb0a4be7ca3149cf46196b599fb8f23301a5b4a4c5154b7419706ba9dd7f279f003692b10fcf406a4159542807baca85683595401479
DIST cvc4-1.8.tar.gz 7554297 BLAKE2B f4d2b223ba2c01ef745520d8874381a1873358fbc7eca12559656512ffeefccec4eca3d73a26debf34110ca14a3bccf35ca87e2a49575b8b67484bed79df081c SHA512 d6b0153b0f5c4e615c995a8eecfbfd783cfc1004c5134c6880230044081c71d638fee39cceb987eb8d72e91b2b6596b184dc0daacec8880cfc176c6dee8aa445
-EBUILD cvc4-1.8-r5.ebuild 1531 BLAKE2B ba2c624ec0f9fc1dca5cbc9fa182be5abeda7195bb50adbe1eb0621b126869596d31651029ce0ebc9b211c695c0de8bfc7613b72cb55a8859fc038d07649ccac SHA512 4321dbf55bbe2269c443a7773fa3f274a3ccb64061ff8ab2fa750ce15a634a81d1f56eadb6de0d47fe0774dc1324b8aa5aab71dfc449de36ccd3a692f7a5a33e
+EBUILD cvc4-1.8-r5.ebuild 1879 BLAKE2B d70a15e577355487d06832a7550af16dfa39096126980c7a16a04769a76798f1f502e5d7bef0d3e30ba0734c15607d655aef89ee5c3562ac64e2982f5d6e2b63 SHA512 11d29e6746c7a5b46ebc98f60e95151ba1b358def7771de74d3e93ab8c252a2c4a08161eb56e5e59f1bf9ed9ccdadb8844b6beceac363243b9957f2ecb7e1c1d
MISC metadata.xml 840 BLAKE2B d452e6a81280e47283c6ff9fa8a800d89c39920e95416e6b25a3bd55663b8ada050b6c7d21b65053ed2e94ae6affb570946fe699bc6efebb26dfcd06dcd0c184 SHA512 603da6ccd58f6d90f8738047c9f93d2c32583242711355fa619f8acaf8694f0cc1e22d41592914a154cc4cfa31b0ab7308e8584c8951bc78a3bdf8e5f130cb04
diff --git a/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild b/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
index 4870f7af7ba6..9bab754168e0 100644
--- a/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
@@ -57,6 +57,17 @@ src_configure() {
-DENABLE_PROOFS="$(usex proofs ON OFF)"
)
cmake_src_configure
+ # Bug #934053 - build with musl
+ antlr3 "${S}"/src/parser/cvc/Cvc.g -fo "${BUILD_DIR}"/src/parser/cvc || die
+ sed -i \
+ -e "s|k = NULL|k = 0|g" \
+ -e "s|n = NULL|n = 0|g" \
+ -e "s|k1 = NULL|k1 = 0|g" \
+ -e "s|k2 = NULL|k2 = 0|g" \
+ -e "s|lo = NULL|lo = 0|g" \
+ -e "s|hi = NULL|hi = 0|g" \
+ "${BUILD_DIR}"/src/parser/cvc/CvcParser.c \
+ die
}
src_test() {