summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cvc4/cvc4-1.8-r5.ebuild')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.8-r5.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild b/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
index 6de0fc9372aa..4870f7af7ba6 100644
--- a/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.8-r5.ebuild
@@ -11,6 +11,8 @@ DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) p
HOMEPAGE="https://cvc4.github.io/"
SRC_URI="https://github.com/CVC4/CVC4-archived/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN^^}-archived-${PV}
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -28,8 +30,6 @@ BDEPEND="$(python_gen_any_dep '
')
"
-S="${WORKDIR}"/${PN^^}-archived-${PV}
-
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-toml.patch
@@ -40,6 +40,13 @@ python_check_deps() {
python_has_version "dev-python/tomli[${PYTHON_USEDEP}]"
}
+src_prepare() {
+ cmake_src_prepare
+ if use elibc_musl ; then
+ eapply "${FILESDIR}"/${P}-musl.patch
+ fi
+}
+
src_configure() {
local mycmakeargs=(
-DANTLR_BINARY=/usr/bin/antlr3