summaryrefslogtreecommitdiff
path: root/sci-mathematics/coq
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/Manifest2
-rw-r--r--sci-mathematics/coq/coq-8.9.1.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/sci-mathematics/coq/Manifest b/sci-mathematics/coq/Manifest
index 5bb4c15ed1f9..3d57543e252f 100644
--- a/sci-mathematics/coq/Manifest
+++ b/sci-mathematics/coq/Manifest
@@ -1,5 +1,7 @@
DIST coq-8.6.1.tar.gz 5588811 BLAKE2B 1016e54ef9b42a8534add55ab057454fad35b3fe103ba877689489c7d9cf43d76c1fbee123801d91035d353a882120650f94c433d9ee1daa878b8c819609c949 SHA512 814ab76a06ca15f927081428da74add4bc67290199fa011853b9c68a00cdefaf813b10fbac18a434f4504fce8f2173eb544080bf6f50d62caa41bb8724b13083
DIST coq-8.6.tar.gz 5538848 BLAKE2B 025d6598a5155712662ce20a56804b75c236f1d1dc4ed81e779aaf2916d5cb525acfcbef9b5960fc5b8b44f2e2290c9f7e5c2d6e84726400a9888587ee29cd16 SHA512 9f5f4913fda8cf83683fec9398b42d4567207c3d4b52b4638d5e09a24ed25a43905fb57a9fac1bb9f9d681bd47f3560e1da74e79348b3a3fd93e2e8c686cebae
+DIST coq-8.9.1.tar.gz 6001970 BLAKE2B f65498e2485c59f4f95d2afeac35750ebf85b5af6db7c269a11635f2414df483d4cb159557060c9118de25f4922176f54d2e5c6f12174599371348341cb4d80f SHA512 66344f801b955d1b6daf3ab1d704551070c95cf9032ae74f15fb33f7ec313812b3e05c0ec277a2eb448e3fdfd9721df06d36612e2fb4928b6530d70147f1d983
EBUILD coq-8.6.1.ebuild 1991 BLAKE2B 625a0e1000c6ee4cd888e97fce07cebf8866ef5f830dd9d5e068bc85b40caae2214d2371409397c80a41d82b5240d864cac05fb31eb9d1810df9470cdda300d3 SHA512 30a6fb585df11a7f45f802dcb8e07c3be23e18c8e17976ecf2add66fe3f23d496099762dd16d11e0f214d9f1be290067dd29e7d4e1bdb7c1d161e52f995f4b64
EBUILD coq-8.6.ebuild 1988 BLAKE2B d0b0a3880313d1f72b0fab73ae0b6afac6e4686aabbbd3dd4e7d21cd09d496088e0593e5b5fc15497f9987f7e51e8f6a58fbd307bc11e24f1af31360564838f2 SHA512 159c3541b12f23abb1de9502de2317d82181642ad5590b6d9225c185437d2730b12b5ffa3d7b7727951fa2da314e3f1db24a598446d7b62f7c1fe248a222fbd3
+EBUILD coq-8.9.1.ebuild 1861 BLAKE2B 545e0f0e4bd0db3a47093ad6851f1ac267187cbaf10066679743ff3e4f4f97d3b8e409a0abe8e3a27d97cc2b2c10a918a993b78be73739a3daa2c88f490f9783 SHA512 4bd89fada8c36d2e62142957a98f983265a184e3e26612874528d1891477bcc3aa106c96e63734d23b249bc8acb890d1beb6f906058d3046e6d35c58bdb74fae
MISC metadata.xml 1113 BLAKE2B 0162bb9994d76c6e3019c5e99459ed2fb5d25e7854213ac90735c9693256cb65d81da48cabf279bb6c8badd028e2f59bcab68a06232c92cc9203db16e36d3f79 SHA512 10bf7af26739a58d7e2165ab8d02b6412540c2abd1e28b800976fd8fc9df78275b5dafbdb2e660eae7fb4946769b41812ee5d2bba931317870d993869d7412b8
diff --git a/sci-mathematics/coq/coq-8.9.1.ebuild b/sci-mathematics/coq/coq-8.9.1.ebuild
new file mode 100644
index 000000000000..a7de5198ee4c
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.9.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RESTRICT=test
+
+# Note: RDEPEND will require dev-ml/num:= for >=dev-lang/ocaml-4.0.7
+RDEPEND="
+ >=dev-lang/ocaml-4.0.5:=[ocamlopt?]
+ dev-ml/camlp5:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[sourceview,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ -prefix /usr
+ -bindir /usr/bin
+ -libdir /usr/$(get_libdir)/coq
+ -mandir /usr/share/man
+ -coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ -docdir /usr/share/doc/${PF}
+ -configdir /etc/xdg/${PN}
+ -lablgtkdir ${ocaml_lib}/lablgtk2
+ )
+
+ use debug && myconf+=( -debug )
+ use doc || myconf+=( -with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( -coqide opt )
+ else
+ myconf+=( -coqide byte )
+ fi
+ else
+ myconf+=( -coqide no )
+ fi
+
+ use ocamlopt || myconf+=( -byte-only )
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README.md CREDITS CHANGES.md
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}