summaryrefslogtreecommitdiff
path: root/sci-mathematics/abc/files/abc-0_p20230313-libabc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/abc/files/abc-0_p20230313-libabc.patch')
-rw-r--r--sci-mathematics/abc/files/abc-0_p20230313-libabc.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sci-mathematics/abc/files/abc-0_p20230313-libabc.patch b/sci-mathematics/abc/files/abc-0_p20230313-libabc.patch
new file mode 100644
index 000000000000..57691dc18775
--- /dev/null
+++ b/sci-mathematics/abc/files/abc-0_p20230313-libabc.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -221,7 +221,7 @@ lib$(PROG).a: $(LIBOBJ)
+
+ lib$(PROG).so: $(LIBOBJ)
+ @echo "$(MSG_PREFIX)\`\` Linking:" $(notdir $@)
+- $(VERBOSE)$(CXX) -shared -o $@ $^ $(LIBS)
++ $(VERBOSE)$(CXX) -shared -o $@ $^ $(LDFLAGS) -Wl,-soname,lib$(PROG).so.0 $(LIBS)
+
+ docs:
+ @echo "$(MSG_PREFIX)\`\` Building documentation." $(notdir $@)