summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin43344 -> 43350 bytes
-rw-r--r--sci-libs/transformers/Manifest2
-rw-r--r--sci-libs/transformers/transformers-4.46.3.ebuild116
3 files changed, 118 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 95837ecf347b..8929ae345fbe 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/transformers/Manifest b/sci-libs/transformers/Manifest
index 6a11ab949c2b..709659237d4c 100644
--- a/sci-libs/transformers/Manifest
+++ b/sci-libs/transformers/Manifest
@@ -1,3 +1,5 @@
DIST transformers-4.45.2.gh.tar.gz 19105135 BLAKE2B 7bccd916de08d480789597c76f042b3941663e9bc9882c9c6b2c3d12ca49a505725ebc944306318fe5f418a36105247ef0729b8a8afc63adfe7c321a2367dea1 SHA512 1006949935b44d6ae0dc464cef9cc23b6c2074ef4a4947c4296ae177fb5348ea8ab0f4fed7da01ed9b67e20985494b07820605b396c30fd02d3ecc01549746d2
+DIST transformers-4.46.3.gh.tar.gz 19535462 BLAKE2B 3687d6a621c7823c35c3de3e0db31bc64d9c39c065936637042be5c4d7ca617083d5143484a24690f8460765e19a14b758c42321235ad09915a23302d3eaea0f SHA512 f07c80c2301b504edbe8cfa8894a420ef9628218a8a3c5a4f6bdab32df4ef020354810a762eee556e7b92c39bf106b65dfc89af53111a3ad06a5a4aabffc8029
EBUILD transformers-4.45.2.ebuild 1074 BLAKE2B dd3872eb7b640e84476e7c33cf32e0115c6a9ffb088ea790ec2905c0fedf0b87289c6114c566aef752dcf54a0a837747066b5bc7050f5c2f64592bf7a9d7971b SHA512 40307ef58aa1bb6687f0aac32a12ba641b11dc6c20edc624b895dc251cba00da0fc4079867e137c55fdc68d44621d9caa9e3cb2d6eb405e44d4f359a959d430c
+EBUILD transformers-4.46.3.ebuild 4793 BLAKE2B 32cb54098a8243fd62d45cd4291a4b25f9e43c1b7bf289a9058b2b48bc020a31cab359b547f8ec9d16124c40618457d7228b66cae8e461d5477cdcc859aefe1d SHA512 277b1a2ea1579eae59320ea3f6359c6092c1de8bfd08ff9422063935d697404756eade02c7050c89e328bab320472af5cfb9edf2dd9e26c59d843e60f77d1f0a
MISC metadata.xml 387 BLAKE2B 3f22d78a1aa32d40204f0c028a564cae5950a3294a7f0ed13c171683a63d2e62892a3740834735a5165745bb477538ac75826fd0c495883bacb32fe22d124621 SHA512 f800c33c27db9b23289e0086f82a80c593b7eeca00cec7bd9c3619e4f074878302c9110117d1a4ddaf789c53a58c4b274d46f4bcea9b8eec477b4fcf8e317a29
diff --git a/sci-libs/transformers/transformers-4.46.3.ebuild b/sci-libs/transformers/transformers-4.46.3.ebuild
new file mode 100644
index 000000000000..ab0f1c5c3c48
--- /dev/null
+++ b/sci-libs/transformers/transformers-4.46.3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow"
+HOMEPAGE="
+ https://pypi.org/project/transformers/
+ https://huggingface.co/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Need some modules, not yet packaged
+
+RDEPEND="
+ =sci-libs/tokenizers-0.20*[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ sci-libs/huggingface_hub[${PYTHON_USEDEP}]
+ >=sci-libs/safetensors-0.4.1[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ tests/deepspeed/test_deepspeed.py
+ tests/deepspeed/test_model_zoo.py
+ tests/fsdp/test_fsdp.py
+ tests/models/bartpho/test_tokenization_bartpho.py
+ tests/models/big_bird/test_modeling_big_bird.py
+ tests/models/cpm/test_tokenization_cpm.py
+ tests/models/layoutxlm/test_processor_layoutxlm.py
+ tests/models/layoutxlm/test_tokenization_layoutxlm.py
+ tests/models/mluke/test_tokenization_mluke.py
+ tests/models/nllb/test_tokenization_nllb.py
+ tests/models/qwen2_audio/test_modeling_qwen2_audio.py
+ tests/models/seamless_m4t/test_processor_seamless_m4t.py
+ tests/models/speech_to_text/test_processor_speech_to_text.py
+ tests/models/speech_to_text/test_tokenization_speech_to_text.py
+ tests/models/speecht5/test_processor_speecht5.py
+ tests/models/speecht5/test_tokenization_speecht5.py
+ tests/repo_utils/test_check_docstrings.py
+ tests/repo_utils/test_tests_fetcher.py
+ tests/trainer/test_trainer.py
+ tests/trainer/test_trainer_callback.py
+ tests/utils/test_file_utils.py
+ tests/models/audio_spectrogram_transformer/test_feature_extraction_audio_spectrogram_transformer.py
+ tests/models/beit/test_image_processing_beit.py
+ tests/models/clap/test_feature_extraction_clap.py
+ tests/models/clip/test_image_processing_clip.py
+ tests/models/clvp/test_feature_extraction_clvp.py
+ tests/models/conditional_detr/test_image_processing_conditional_detr.py
+ tests/models/dac/test_feature_extraction_dac.py
+ tests/models/deformable_detr/test_image_processing_deformable_detr.py
+ tests/models/encodec/test_feature_extraction_encodec.py
+ tests/models/grounding_dino/test_image_processing_grounding_dino.py
+ tests/models/idefics/test_image_processing_idefics.py
+ tests/models/idefics2/test_image_processing_idefics2.py
+ tests/models/llava_next/test_image_processing_llava_next.py
+ tests/models/llava_next_video/test_image_processing_llava_next_video.py
+ tests/models/llava_onevision/test_image_processing_llava_onevision.py
+ tests/models/markuplm/test_feature_extraction_markuplm.py
+ tests/models/mask2former/test_image_processing_mask2former.py
+ tests/models/maskformer/test_image_processing_maskformer.py
+ tests/models/musicgen_melody/test_feature_extraction_musicgen_melody.py
+ tests/models/oneformer/test_image_processing_oneformer.py
+ tests/models/oneformer/test_processor_oneformer.py
+ tests/models/pix2struct/test_image_processing_pix2struct.py
+ tests/models/pixtral/test_image_processing_pixtral.py
+ tests/models/pop2piano/test_feature_extraction_pop2piano.py
+ tests/models/qwen2_vl/test_image_processing_qwen2_vl.py
+ tests/models/seamless_m4t/test_feature_extraction_seamless_m4t.py
+ tests/models/segformer/test_image_processing_segformer.py
+ tests/models/seggpt/test_image_processing_seggpt.py
+ tests/models/speech_to_text/test_feature_extraction_speech_to_text.py
+ tests/models/speecht5/test_feature_extraction_speecht5.py
+ tests/models/superpoint/test_image_processing_superpoint.py
+ tests/models/univnet/test_feature_extraction_univnet.py
+ tests/models/wav2vec2/test_feature_extraction_wav2vec2.py
+ tests/models/whisper/test_feature_extraction_whisper.py
+ tests/models/yolos/test_image_processing_yolos.py
+ )
+
+ local EPYTEST_DESELECT=(
+ tests/repo_utils/test_check_copies.py::CopyCheckTester::test_is_copy_consistent
+ tests/repo_utils/test_check_copies.py::CopyCheckTester::test_is_copy_consistent_with_ignored_match
+ tests/repo_utils/test_check_copies.py::CopyCheckTester::test_is_copy_consistent_with_ignored_no_match
+ )
+
+ EPYTEST_FLAGS="--dist=loadfile -s ./tests/"
+
+ distutils-r1_src_test
+}