summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin43137 -> 43131 bytes
-rw-r--r--sci-libs/onnx/Manifest2
-rw-r--r--sci-libs/onnx/onnx-1.16.2.ebuild71
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index ce21782f7790..9618413ab3fe 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index fdb4d1f38f5c..2e5b174e139f 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -1,4 +1,6 @@
AUX onnx-1.15.0-hidden.patch 511 BLAKE2B 857a4ff9597a25430e2236c2d9de47c1203e630a4adfe8e4cdb72ddfb928f0327e2a625ad91e936e4d3f71bc4aa135bbd15abcf348958238075d356d47d3291b SHA512 a4dbcbae79af1ef1edc8ec8aa27eb0303c1a52baf7db74e70f2d1e6a35db7d5ed2205f7f10f34fdcd3ac536b029edf749b9eb8f7926ac2b620ac7a4b59884182
DIST onnx-1.16.1.tar.gz 12428832 BLAKE2B 15a7db2fa263914957c671bd8e94eb8b80afeba0b396e8b54f8fb2deda2965885055efae7a6f6e402eb085b5795025020f650132023ba3d4df1f395d99ec353c SHA512 0ae1b36563ddeaa9947bf452eb20b83174e4c2bc4696b61768f096c401666323343fac0f699f756da99d3c29df15a0bd78fe3fa51da15f133617d7310c5b28d4
+DIST onnx-1.16.2.tar.gz 12429500 BLAKE2B 1541fd9e80e305bc0764d1f5d236a89a2f0d0d8819bd6f235c88d35985daf02f575854a537af193befbeab861b2fe6a9d5b8803975b8ae6a47d5d5a6dc28b661 SHA512 7a9a8493b9c007429629484156487395044506f34e72253640e626351cb623b390750b36af78a290786131e3dcac35f4eb269e8693b594b7ce7cb105bcf9318d
EBUILD onnx-1.16.1-r1.ebuild 1474 BLAKE2B 4eae3a54c71f15ea97c8d4207857bfb87aa40948e82c458081d4eafa394e4658d226d9265b803e21cf239759d6bc25593c06dad86a51b376ab8c9a50b55dac54 SHA512 39a525375826883195750efa901e8c35512c10484d4868ad2c088db6d805e7ad63c46c4f70db229e610411dd58cfc4bc4bd4259ae292551646230601ad35c8d9
+EBUILD onnx-1.16.2.ebuild 1474 BLAKE2B 4eae3a54c71f15ea97c8d4207857bfb87aa40948e82c458081d4eafa394e4658d226d9265b803e21cf239759d6bc25593c06dad86a51b376ab8c9a50b55dac54 SHA512 39a525375826883195750efa901e8c35512c10484d4868ad2c088db6d805e7ad63c46c4f70db229e610411dd58cfc4bc4bd4259ae292551646230601ad35c8d9
MISC metadata.xml 404 BLAKE2B 363f1790f0dd2eace0368d7eb1875c166ba6dd0b2514232050f2f1813ccba854b4f8e58e22a329792126188f06d21bf87436c1dcc10d68b018f7abc8eb8ec3e9 SHA512 6a80de77d763a261cafee9cd69337de5282fa39772a1d2a82c3d954d29221596036346339926a124f9df9b261050d17b58d004cdd01ff2f57347379e9df2e45f
diff --git a/sci-libs/onnx/onnx-1.16.2.ebuild b/sci-libs/onnx/onnx-1.16.2.ebuild
new file mode 100644
index 000000000000..0e8227eb2487
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.16.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="disableStaticReg"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-libs/protobuf:=
+ dev-cpp/abseil-cpp:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.15.0-hidden.patch
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_configure_all()
+{
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
+ )
+ cmake_src_configure
+}
+
+src_configure() {
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
+ )
+ CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
+}
+
+python_compile_all() {
+ cmake_src_compile
+}
+
+python_install_all() {
+ cmake_src_install
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
+}