summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin44344 -> 44350 bytes
-rw-r--r--sci-libs/arprec/Manifest2
-rw-r--r--sci-libs/arprec/arprec-2.2.19-r1.ebuild (renamed from sci-libs/arprec/arprec-2.2.19.ebuild)27
3 files changed, 16 insertions, 13 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index 1e91fce6ea5a..77747cc4f77b 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/arprec/Manifest b/sci-libs/arprec/Manifest
index 74ada363f837..0289965b68f4 100644
--- a/sci-libs/arprec/Manifest
+++ b/sci-libs/arprec/Manifest
@@ -1,4 +1,4 @@
AUX arprec-2.2.19-gold.patch 477 BLAKE2B 128d84824143a6af222f92462efd58d22ae014e359555b59380bd0060faea249a879244baca3cf7c2d81510070647c49414c4589efce5ce40328a6f3871e387f SHA512 f8a6408916b26a395832a6bd55f43de7153ceab5a343df1f974a2dd9e6ae3eec1b2533db36a11061e74f15f471dcff52a3247681e8872b15dfb8115f9b406cf6
DIST arprec-2.2.19.tar.gz 1962133 BLAKE2B a2fccc1908e791fd4759e61ff52b180fcaccbfbfa831ee1beca9b22a1a745d17d21040974ffe02ea21397a2339c819a30cd93a247738564a2b433f7cef14c9e4 SHA512 97cf090398aa169e31711077efd26dc6da1f62291ab37b241b133634838bdd44743f85b86b861a3be18d2696ae9132afb6cd1871502bedb9cc17dfb63fde2632
-EBUILD arprec-2.2.19.ebuild 1569 BLAKE2B 842a8e76f459fef164ecc204e8437a4143cc33567a035243d6540a3aaae9c693ba2d1142fb81a02b422095ef5fee8e5e4fa36dea41cdf405e1081b70a3de534d SHA512 23333b1466a36adf24ce851491c4416b5fa71267fd730e82c8c39636f992a851191ca0469670b3442b49bed27bb06cfa267c064aeef29a77feaf6fcce90bf369
+EBUILD arprec-2.2.19-r1.ebuild 1677 BLAKE2B 2947afab366c2dce8af1eae8a34ef1c9b1fc48145776ed1648cff919b1345c6884b6230ef43b84a15ce9895e1c10d5334ee08a15ba7ef76d8cb4847b657623a7 SHA512 2da0c32c69e31e7979831cef4e7f6c158a043cd36b825a04d75a7e702fa82c0459916034b5d552ccc1115125becd1659fa4d942a890e7f8e022e5b020d4ffde7
MISC metadata.xml 356 BLAKE2B b8983f8e4e77d7814881864e619a0e8b65c3171ba799b4f67893c91f944674c53a0ef3f9ab0c260fd3f9f4867fadf8001aa25e1ec94542d80544c004428ac004 SHA512 e12f234f82992d14f0c0a86e654a070e0ccc6fd3c0e6ac824371ac647ab4264b6406b81b57273aa68e1ff6625e8cded8adf6a300145e429b0c7ee695245e3500
diff --git a/sci-libs/arprec/arprec-2.2.19.ebuild b/sci-libs/arprec/arprec-2.2.19-r1.ebuild
index b31b5b5c86c7..dc6ff68e1078 100644
--- a/sci-libs/arprec/arprec-2.2.19.ebuild
+++ b/sci-libs/arprec/arprec-2.2.19-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
FORTRAN_NEEDED=fortran
FORTRAN_STANDARD=90
@@ -11,9 +11,10 @@ inherit autotools fortran-2
DESCRIPTION="Arbitrary precision float arithmetics and functions"
HOMEPAGE="https://crd-legacy.lbl.gov/~dhbailey/mpdist/"
SRC_URI="https://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran qd static-libs"
@@ -24,20 +25,22 @@ PATCHES=(
"${FILESDIR}"/${P}-gold.patch
)
-S="${WORKDIR}/${PN}"
-
src_prepare() {
default
+ sed -e '/TESTS =/s/ io//' -i tests/Makefile.am || die # bug 526960
+
eautoreconf
}
src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
- $(use_enable fortran) \
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma)
+ $(use_enable fortran)
$(use_enable qd)
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {
@@ -75,10 +78,10 @@ src_install() {
fi
if ! use doc; then
- rm "${ED%/}"/usr/share/doc/${PF}/*.pdf || die
+ rm "${ED}"/usr/share/doc/${PF}/*.pdf || die
fi
if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -type f -name '*.la' -delete || die
fi
}