summaryrefslogtreecommitdiff
path: root/sci-libs/vtk/vtk-9.1.0-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/vtk/vtk-9.1.0-r6.ebuild')
-rw-r--r--sci-libs/vtk/vtk-9.1.0-r6.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/sci-libs/vtk/vtk-9.1.0-r6.ebuild b/sci-libs/vtk/vtk-9.1.0-r6.ebuild
index f2d49d2249e2..e781751ccfda 100644
--- a/sci-libs/vtk/vtk-9.1.0-r6.ebuild
+++ b/sci-libs/vtk/vtk-9.1.0-r6.ebuild
@@ -188,6 +188,12 @@ pkg_pretend() {
# 10.2 GiB install directory, 6.4 GiB build directory with max. USE flags
CHECKREQS_MEMORY="7G"
CHECKREQS_DISK_BUILD="14G"
+ if [[ ${VTK_CUDA_ARCH} = native ]]; then
+ eerror "Using native CUDA arches is currently broken."
+ eerror "Please set it to one of the common arch names:"
+ eerror "kepler, maxwell, pascal, turing or ampere."
+ die "Please set VTK_CUDA_ARCH environment variable!"
+ fi
fi
if use qt6 && use qt5; then
@@ -217,6 +223,12 @@ pkg_setup() {
if use cuda; then
CHECKREQS_MEMORY="7G"
CHECKREQS_DISK_BUILD="14G"
+ if [[ ${VTK_CUDA_ARCH} = native ]]; then
+ eerror "Using native CUDA arches is currently broken."
+ eerror "Please set it to one of the common arch names:"
+ eerror "kepler, maxwell, pascal, turing or ampere."
+ die "Please set VTK_CUDA_ARCH environment variable!"
+ fi
fi
if use qt6 && use qt5; then