summaryrefslogtreecommitdiff
path: root/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild')
-rw-r--r--sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild b/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
new file mode 100644
index 000000000000..36f86cfa54bf
--- /dev/null
+++ b/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="ANOVA Extensions to the GNU Scientific Library"
+HOMEPAGE="https://tracker.debian.org/pkg/tamuanova"
+SRC_URI="http://cdn-fastly.deb.debian.org/debian/pool/main/t/tamuanova/tamuanova_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="sci-libs/gsl:0="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}"/${PN}-0.2
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+ "${FILESDIR}"/${P}-texinfo5.1.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}