summaryrefslogtreecommitdiff
path: root/sci-libs/stellarsolver/stellarsolver-2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/stellarsolver/stellarsolver-2.5.ebuild')
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.5.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/stellarsolver/stellarsolver-2.5.ebuild b/sci-libs/stellarsolver/stellarsolver-2.5.ebuild
index 1473c730ee95..c7e235ccd58b 100644
--- a/sci-libs/stellarsolver/stellarsolver-2.5.ebuild
+++ b/sci-libs/stellarsolver/stellarsolver-2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
HOMEPAGE="https://github.com/rlancaste/stellarsolver"
@@ -25,3 +25,10 @@ RDEPEND="
sci-astronomy/wcslib:=
"
DEPEND="${RDEPEND}"
+
+src_configure() {
+ # bug #862930
+ filter-lto
+
+ cmake_src_configure
+}