summaryrefslogtreecommitdiff
path: root/sci-libs/starparse/starparse-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/starparse/starparse-1.0-r1.ebuild')
-rw-r--r--sci-libs/starparse/starparse-1.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/starparse/starparse-1.0-r1.ebuild b/sci-libs/starparse/starparse-1.0-r1.ebuild
new file mode 100644
index 000000000000..3d11e67b51fd
--- /dev/null
+++ b/sci-libs/starparse/starparse-1.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+# Created from rev 19 @ http://oregonstate.edu/~benisong/software/projects/starparse/releases/1.0
+SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="guile static-libs test"
+
+REQUIRED_USE="test? ( guile )"
+
+RDEPEND="guile? ( dev-scheme/guile:12 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-guile1.8.patch )
+
+src_configure() {
+ local myeconfargs=( $(use_enable guile) )
+ autotools-utils_src_configure
+}