summaryrefslogtreecommitdiff
path: root/sci-libs/shapely
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/shapely')
-rw-r--r--sci-libs/shapely/Manifest5
-rw-r--r--sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch17
-rw-r--r--sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild57
-rw-r--r--sci-libs/shapely/shapely-1.7.0.ebuild39
4 files changed, 0 insertions, 118 deletions
diff --git a/sci-libs/shapely/Manifest b/sci-libs/shapely/Manifest
index be3d0db03bb6..801097a3d181 100644
--- a/sci-libs/shapely/Manifest
+++ b/sci-libs/shapely/Manifest
@@ -1,8 +1,3 @@
-AUX shapely-1.6.4_p2-test_operations.patch 722 BLAKE2B 661659bc1d2f8c8a5d6b77f0ca746024aa9724f2c25047d8203d591a4f793982d4cf9bebaa6abcaf48c0cf1b266ef941b986897d26bece39519f8fcaf5dcaf96 SHA512 c1e9eda0cf8dbfbcee2d6994f470559507c754fa2bf03973ac692ca6bd2fcf62ce05e15116515877e8900a89c55c6b2bf6e70b74e2cfced8d3852608901b34db
-DIST Shapely-1.6.4.post2.tar.gz 225745 BLAKE2B 96e995db6dd1464bac7c2562efdc7f298a5f23c388e44f334db685b1cfa1025ff403db870e11328977a267483726504e03b6d7c47fe4234a3a5966a13b2b7311 SHA512 027c816ef2104f654569ca658b52b87c60e5ba6a45927fcc51c23dd1922f3f9f7fdcea3601160b0a999e39611617142833ccac790777093be8b96a0d9083f78f
-DIST shapely-1.7.0.tar.gz 281419 BLAKE2B 1a4e84104f21d2f5a5eb810883a89deb20fd47cf146efed884994786364b29bb5a194b063a50ae21842c07c335cbbee0c3d1a1e4ff4e43e0d083080fe33815ac SHA512 4d944fc6727e11d004ef7ba0325c159aa5ae03043f17b029ab0a399d6dcd361c4d299ad864a045a99b0229e333d5b42634bc6fd1ed94b914b7cf58fb886af2de
DIST shapely-1.7.1.tar.gz 293368 BLAKE2B 14d9cb0c2b486a3a20b71c0cde7260ec357287ea020352c0320eea07b91674605bdcd22512b33c5ac5a71b89c3d811946f8dd6d3b90c61398203a4c68f30d067 SHA512 72070437960a8c1cf6504b5f4ccc8ec509f87fb6a90178e291aff14889f5add89f9ed4f7e9a19799ce0835c1aea3f0241eaa6efd4d8ea5b879f2167f7c1de50a
-EBUILD shapely-1.6.4_p2-r1.ebuild 1261 BLAKE2B 642299e5826a038c523a5bced181f9bbfedccd6cc09f9e7420ff8182f425ea94e54989fb595659a2e8a25054e40c80ea0ea1621d198e986b83432faf54e8edad SHA512 5a2df29e69ed543ee8bdcf3a9b972769a95000be8948ee2e08f0ed86d867b41eb4713d8137bbc9add0af9f888791c7a6d67e9e025374b867d7df3356b3ca7557
-EBUILD shapely-1.7.0.ebuild 841 BLAKE2B 215c6b3cbef150d7de204c0537962c68851578404ae0aeac37ee7339e74fdec6e4559dcb776c45be83eb56093f6b822ce41978132291495d98b892746388cac4 SHA512 4e19ff01ef50b6ce96a70052725d1bbf57f39d46d3305c9ac5fb12bec0581abf3c009ee2daae636ae3c57ae4ab35a70c08bf71d50fe5e0e9774fec5f59fe86ff
EBUILD shapely-1.7.1.ebuild 839 BLAKE2B cdff940dce5acbd360bb81467475bdf7bd95d512f23c45c9bc7604c6769d56f5e111e0c6a830ab3c79ef84b17fe9878eb424ddd56b62588a80cb18115b68af2e SHA512 407d39827d32b759fc7944195bed880243424374555471a283700c47426e39ab3ec57ec6808e41b9670f1783f580f19737c0aeb12ca2f39da1ef32bf6e17e0e5
MISC metadata.xml 783 BLAKE2B 365db96ce9bd755cd3c080f84883666ceb74d1b78a5a0692552f53a6a5b5dd468c973857f0d0e860ffc6a78c623518e6bd781682118ff0d1e355fca68bdc861c SHA512 e97b0011a6581773ddc9b13879517f2295c850822f267dc3af34b4dae0683f3e0e3b60900b2cf6206084da7bc32561e42f64e7c3709461a40305bf821667450b
diff --git a/sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch b/sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch
deleted file mode 100644
index a9213a333765..000000000000
--- a/sci-libs/shapely/files/shapely-1.6.4_p2-test_operations.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Mark test_operations as xfail.
- # Intersection
- > self.assertIsInstance(point.intersection(Point(-1, -1)),
- GeometryCollection)
- E AssertionError: <shapely.geometry.point.Point object at 0xffffb6e2c250> is not an instance of <class 'shapely.geometry.collection.GeometryCollection'>
-Author: Bas Couwenberg <sebastic@debian.org>
-
---- a/tests/test_operations.py
-+++ b/tests/test_operations.py
-@@ -7,6 +7,7 @@ from shapely.geos import TopologicalErro
-
- class OperationsTestCase(unittest.TestCase):
-
-+ @pytest.mark.xfail(reason="Intersection: Point is not an instance of GeometryCollection")
- def test_operations(self):
- point = Point(0.0, 0.0)
-
diff --git a/sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild b/sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild
deleted file mode 100644
index be793427c4b7..000000000000
--- a/sci-libs/shapely/shapely-1.6.4_p2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="Shapely"
-MY_PV="$(ver_cut 1-3).post$(ver_cut 5)"
-MY_P="${MY_PN}-${MY_PV}"
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="https://pypi.org/project/Shapely/"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/Toblerity/${MY_PN}.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/geos-3.3"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=( "${FILESDIR}/${P}-test_operations.patch" ) # bug 701624
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # fix install path for Cython definition file
- sed -i \
- -e "s|\(data_files.*\)'shapely'|\1'share/shapely'|" \
- setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}/lib" || die
- cp -r "${S}/tests" . || die
- py.test tests || die
-}
diff --git a/sci-libs/shapely/shapely-1.7.0.ebuild b/sci-libs/shapely/shapely-1.7.0.ebuild
deleted file mode 100644
index 3e2d10095cec..000000000000
--- a/sci-libs/shapely/shapely-1.7.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="Shapely"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{7..8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="https://pypi.org/project/Shapely/ https://github.com/Toblerity/Shapely"
-SRC_URI="https://github.com/Toblerity/Shapely/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/geos-3.3
-"
-
-BDEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${MY_P}"
-
-distutils_enable_tests pytest
-
-distutils_enable_sphinx docs dev-python/matplotlib
-
-python_test() {
- distutils_install_for_testing
- ${EPYTHON} -m pytest tests || die "tests failed under ${EPYTHON}"
-}