summaryrefslogtreecommitdiff
path: root/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild')
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
index a196780e222e..7c554093db97 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
@@ -82,14 +82,14 @@ src_prepare() {
# Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5, unpack and convert them into csr format
# This process is handled default by ${S}/cmake/ClientMatrices.cmake, but should be the responsibility of portage.
if use test; then
- mkdir -p "${BUILD_DIR}"/matrices
+ mkdir -p "${BUILD_DIR}"/clients/matrices
# compile and use the mtx2csr converter. Do not use any optimization flags, because it causes error!
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
- destination=${BUILD_DIR}/matrices/$(basename -s '.mtx' ${mtxfile}).csr
+ destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).csr
ebegin "Converting ${mtxfile} to ${destination}"
deps/convert ${mtxfile} ${destination}
eend $?